Mysql error eating up my computer - htop

My system is running really slowly so i ran htop from the command line and I’m seeing this as eating up all of my computer usage: If I kill this will it ruin anything?

I was able to obtain a few more of these processes that are killing my server

I upgraded all of the modules and restarted freepbx with no effect on the pid killing my computer usage

mysql> show PROCESSLIST;
+--------+-------------+-----------------+---------------+---------+-------+----                                                                                                    ---+------------------+
| Id     | User        | Host            | db            | Command | Time  | Sta                                                                                                    te | Info             |
+--------+-------------+-----------------+---------------+---------+-------+----                                                                                                    ---+------------------+
| 760308 | freepbxuser | localhost       | asteriskcdrdb | Sleep   |    42 |                                                                                                           | NULL             |
| 766373 | freepbxuser | localhost:38514 | asterisk      | Sleep   | 15540 |                                                                                                           | NULL             |
| 767906 | root        | localhost       | NULL          | Query   |     0 | NUL                                                                                                    L  | show PROCESSLIST |

Do you think it is the Sleep command with the 15540 time? Ive run the mysql auto repair codes with no change

Have you restarted mysql in the last 4 and a half hours?

I do not believe so. The system itself has been up for ~2wk. I have run updates and restarted freepbx

Restarting mysql should have no impact and should clear any stu k processes.

service mysql restart or service mysqld restart?

I’m assuming this will drop any active calls

No calls will be dropped, depends on your os, redhat uses mysqld

It seemed to clear up the issue temporarily but then as I’m watching the processes (htop) within a few minutes that same mysql process is back taking up all of my computer %

show full PROCESSLIST;

Use netstat to see what process is connecting to mysql on port 47278 , my guess its ucp’s nodejs

tcp 0 0 securesipwilder.copoc:mysql securesipwilder.copoc:47278 ESTABLISHED

netstat -ntpa|grep 3306

That is as suspected the ucp process, disable it temporarily and see what happens

This is just the craziest thing. I disabled ucp and ucp node server. I restarted mysqld and pretty soon its back