MWI Long Delay

Have a PBXAct appliance with a handful of Sangoma P310 series phones. Out of the say 20 extensions only two of them apparently have MWI issues.

Now when I called and tested leaving voicemails the light came on instantly. However these two users keep saying they don’t get an alert that they have a voicemail until “days” later. When I tested it was instant.

Any ideas for what could possibly cause delays in getting a visual notification? I would assume but hard to test, that if they were to call their voicemail directly since it pulls the voicemail from the PBX Server via the voicemail service in that case that there would be no delay and that its just simpily a delay in their indication light on the phone.

Not sure how to diagnose… Thanks :slight_smile:

Hi @edricksmith
I will suggest you to check first Sangoma P310 Phone firmware version and update to latest one.
also check from your PBX --> EPM (EndPointManager) , Provisioning Protocol type ( HTTP, HTTPS, TFTP)


Hi sorry shahin, I’m not sure how checking the provisioning type would help? Just curious so I could better understand.

I will check the firmware, this is a new deployment from about 3 months ago, so the system at that time was fully updated and latest firmware and its apparently only affecting these two phones.

So I’m trying to determine what possible reasons only 2 out of 20 phones would be affected by an apparently delayed message indicator. But both times I tried it was instant… so its tough to track down

Hi @edricksmith
I can sent and recommended you FreePBX Wiki page to check and read Auto-Provision methods ( HTTP / HTTPS ) for just information:

So, You are saying of the 20 phone only 2 phones you have this issue…
Question is : 1- How you setup your phones? Manual or Automatically via Zero-Touch or Auto-Provisioning ?
2- Which Protocol you are using ? HTTP or TFTP atm ?
3- What is the this 2 phones firmware version ? are the same as other phones ?
4- This 2 phone (Users or Ext Accounts ) settings are the same on User Manager Group ? ( User Manager --> Group --> Phones and Apps Permissions )

5- Did you tried to swap one of this 2 phone with normal working Ext. Account ?
6- on EPM Phone map which color you are seeing ? Amber or Green ? When you pressed on EPM Update Extension ( selected issue one ) phone is responding to your update or not ?
(Check Section ^^ Color Coding of Extensions in Extension Mapping. )

I think you need to look ^^ all this steps & settings also permissions, but i think ( guess ) issue base on your phone setup if you done manually config via TFTP…



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.