Music on Hold

I have problems uploading multiple mp3 on music on hold, it will not follow upload order.


1 Message ASAP
2 music 30seconds
3 Message 60 Secs
4 music 30seconds
5 Message 90 Secs
6 music 60seconds
7 Message 2 Mins

I upload the files in those order but a different order will appear once all mp3 is uploaded.

Help is much appreciated



Not sure if that version has the “Disable Random Play” feature in the music on hold page for your version of FreePBX.

That would be my guess…

I have that button here “Disable Random Play” feature ill try disabling that feature and see for my self.

Thank for the response

I would disable random play and make sure the file names are in sequential order, not just the order in which they are uploaded.

Why use mp3s and not wave?

i renamed the files ending in a1,a2,b3,b4 ect. this seems to work for me. only had 6 files to sequence. try it and see if it works for you … good luck