FreePBX | Register | Issues | Wiki | Portal | Support

Music on hold not working after migration from elastix

configuration
Tags: #<Tag:0x00007fb90cf1dca0>

(Philip Arny) #1

I recently migrated from Elastix 2.5, which was running on top of FreePBX 2.11.10 r17, to FreePBX-SNG7-FPBX-64bit-1707-1. Updated everything to current. Running Asterisk 13.17.1.

I can’t get music on hold to work. When I got to settings/music on hold and create a new category, it doesn’t show any available music files.

In musiconhold_additional.conf, there’s the line:
directory=/var/lib/asterisk/moh/.nomusic_reserved
what does the .nomusic_reserved mean here? That there’s no music here?

If I look in /var/lib/asterisk/moh, there are a number of files, including
macroform-cold_day.wav, manolo_camp-morning_coffee.wav, macroform-robot_dity.wav, reno_project-system.wav, macroform-the_simplicity.wav, and the same files with .alaw and .sln16 extensions. All are owned asterisk:asterisk.

So I think the music is there, and FreePBX isn’t seeing it.

Any ideas on what I can do to fix this?

Thanks.


(James Zhu) #2

Please show the MOH log, maybe it can help you debug.


(Philip Arny) #3

Got it. The default music on hold group didn’t exisit. Created a new music on hold category, copied the existing music from /var/lib/asterisk/moh to /var/lib/asterisk/moh/newcategory and changed the music on hold setting in my inbound route to the new category. Working!