Multiples Grupos MFCR2 Fracionado 10 Canales


(Alan Chavira) #1

Tengo configurado un E1 10 canales MFCR2 con un Xorcom Astribank, todo configurado via CLI nada web; el detalle viene por que tengo dos grupos g0=ch1-5 g1=ch6-10 y esos grupos al intentar hacer las dos troncales dahdi solo me aparece g0 ya que en el gui solo esta creado el grupo g0; no se si se pueda o exista la forma de poner manualmente el grupo?

La unica forma que eh visto para que me salgan mas grupos es en el gui creandolos en base a 30 canales segun se aprecia en la imagen.

Espero haberme explicado, lo unico que estoy buscando es que al crear la troncal dahdi ponerle g0 o g1 para que tome los canales asignados.

Saludos


(Alan Chavira) #2

Imagen para crear grupos via gui

Saludos


(Ernesto Casas) #3

Priemro que nada, Entra en el Module Admin y haz un check online para ver que version del modulo de Dahdi estas usando y si hay una version nueva que no hayas actualizado.


(Alan Chavira) #4

Que tal,
Tengo lo siguiente:
DAHDi Config 13.0.33.11 Stable, no aparece ningun update.

Saludos


(Gerardo Barajas) #5

Que tal Alan.
Ese bug de momento no tiene que ver con la configuración de MFCR2/ DAHDI

Si ya creaste tus troncales DAHDI en la sección de ‘Trunks’ y vuelves a mirar y aun te aparece como Group 0 Ascending o algo así o no te deja hacerlo, es tema del framework de la parte de Trunks.

Ya está reportado y en proceso de resolución.

En cuanto tengamos información, máximo dos semanas, te lo hacemos saber.

Saludos!


(Gerardo Barajas) #6

Estan todos tus módulos actualizados?

Saludos.


(Alan Chavira) #7

Que tal Gerardo,
Todos los modulos estan actualizados.
Como comentas no tengo problema con el MFCR2, mas bien es en la parte del trunk al tratar de asignar g0 u g1 ya que solo aparece g0 aun cuando en chan_dahdi tengo varios grupos.

Saludos


(Gerardo Barajas) #8

Hola Alan,
acabo de instalar un FreePBX y actualize todos los módulos con

fwconsole ma upgrdeall

Y no tengo problemas para generar los grupos en el módulo de Trunks


(Alan Chavira) #9

No se si tenga que ver que el astribank lo configure via cli no gui, y es en el cli donde defino g0 y g1 pero ya cuando haces el trunk dahdi solo me sale g0.
Me recomiendas configurar el astribank via gui?

Saludos


(Alan Chavira) #10

Aunque si lo configuro via gui no vi omo poner e1 de 10 canales, siempre me aparece full


#11

Yo, edito manualmente los archivos para evitar problemas (/etc/dahdi/system.conf y /etc/asterisk/chan_dahdi.conf), ahi podras hacer la configuracion de los 10 canales que necesitas.
y no se te olvide desinstalar el modulo de dahdi del freepbx.


(Gerardo Barajas) #12

Dahdi-config no te permite partir el E1 como lo tienes en la primer imagen que enviaste?

Te recomiendo que para todo uses dahdi-config, ya que para eso fue escrito :wink:

Si continuas con los problemas, levanta un ticket en español y te ayudamos.

Saludos.


(Ernesto Casas) #13

En todo caso, si bien no esta la opcion para cambiar el nuemro total de canales (Cosa que voy a sugerir que se agregue), siempre puede crea le Grupo 0 con los 10 canales, y si bien el resto quedan asigandos al siguiente grupo, simplemente no los usas.


(Alan Chavira) #14

Efectivamente lo deje como comentaste Ernesto, cree el grupo donde comentas y ya hice mi workaround jeje.
Saludos


(Ernesto Casas) #15

Bien!!.. Voy a pedir que se incluya la opcion de cambiar los canales en proximas versiones.

Un Abrazo!


(Alan Chavira) #16

Seria bueno si es que se puede que cuando creas trunk dahdi puediera estar la opcion custom (es decir poder poner manualmente g0,g1,etc)

Saludos


(Astrosendero) #17

Amigo buenas noches, puedes compartirnos como esta tu archivo /etc/asterisk/chan_dahdi.conf ?


(Astrosendero) #18

Hola Amigo, puedes compartirme tu configuracion del E1 Fraccionado de 10 canales?
para uno de 30 esta asi:

#autogenerated by /usr/sbin/wancfg_dahdi do not hand edit
#autogenrated on 2019-11-01
#Dahdi Channels Configurations
#For detailed Dahdi options, view /etc/dahdi/system.conf.bak
loadzone=mx
defaultzone=mx

#Sangoma A101 port 1 [slot:4 bus:5 span:1]
span=1,1,0,cas,hdb3
cas=1-15:1101
cas=17-31:1101
echocanceller=mg2,1-15,17-31

Para el archivo /etc/asterisk/chan_dadhi.conf

;For detailed Dahdi options, view /etc/asterisk/chan_dahdi.conf.bak

[trunkgroups]

[channels]
language=es
context=from-pstn
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no

;Sangoma A101 port 1 [slot:4 bus:15 span:1]

immediate=no
signalling=mfcr2
mfcr2_variant=mx
mfcr2_get_ani_first=no
mfcr2_max_ani=10
mfcr2_max_dnis=4
mfcr2_category=national_subscriber
mfcr2_mfback_timeout=-1
mfcr2_metering_pulse_timeout=-1
mfcr2_forced_relaase=no
; this is for debugging purposes
mfcr2_logdir=log
mfcr2_logging=all
; end debugging configuration
context=from-pstn

echocancel=256
echocancelwhenbridged=no
echotraining=no
group=0
channel =>1-15,17-31


#19

hola [astrosendero]
system.conf
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-31
dchan=16
echocanceller=mg2,1-15,17-31
loadzone = mx
defaultzone = mx

y el chan_dahdi.conf

[trunkgroups]

[channels]
usecallerid=yes
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancelwhenbridged=yes
busydetect=yes
busycount=1
immediate=no
language=es
context=from-pstn
group=0
echocancel=yes
echocancelwhenbridged=yes
signalling=mfcr2
mfcr2_variant=mx
mfcr2_get_ani_first=no
mfcr2_max_ani=10
mfcr2_max_dnis=4
mfcr2_category=national_subscriber
mfcr2_mfback_timeout=-1
mfcr2_metering_pulse_timeout=-1
mfcr2_forced_relaase=no
mfcr2_logdir=log
mfcr2_loggin=all
callgroup=1
pickupgroup=1
channel =1-15
channel =17-31


(Lorne Gaetz) closed #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.