Multiple modules disabled after fresh install

Just did a fresh install with FreePBX 13 and Asterisk 13 using the latest download as of yesterday 6/20. Internet connection was fine and said it was updating all modules. Logging into the GUI there are over 60 modules disabled pending upgrade. Is this normal? I can manually go in and upgrade each one, but seems like i shouldn’t have to do this.

In the console…

fwconsole ma upgrade framework
fwconsole reload
fwconsole ma upgradeall

I’m having exactly the same issue.

When I ran these commands I got:

# fwconsole reload
Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 1
Exception: Unable to locate the FreePBX BMO Class 'Sipsettings'A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install sipsettings 2) fwconsole ma enable sipsettings in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 216
Stack trace:
  1. Exception->() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:216
  2. FreePBX\Self_Helper->loadObject() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:104
  3. FreePBX\Self_Helper->autoLoad() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:37
  4. FreePBX\Self_Helper->__get() /var/www/html/admin/modules/core/
  5. FreePBX\modules\Core\Drivers\PJSip->generateEndpoints() /var/www/html/admin/modules/core/
  6. FreePBX\modules\Core\Drivers\PJSip->genConfig() /var/www/html/admin/modules/core/Core.class.php:607
  7. FreePBX\modules\Core->genConfig() /var/www/html/admin/libraries/BMO/FileHooks.class.php:97
  8. FreePBX\FileHooks->processNewHooks() /var/www/html/admin/libraries/BMO/FileHooks.class.php:26
  9. FreePBX\FileHooks->processFileHooks() /var/lib/asterisk/bin/retrieve_conf:879

I have tried installing this twice and got the same results.

I have also tried following guides on fixing this error listed above, but none of the solutions worked for me.

This is what I am seeing instead of the dashboard.

This is what I see on Module Admin

Yes this was fixed yesterday. To fix it you’ll have to upgrade framework to 13.0.142 then AFTER that it’ll be resolved. I said after because the new files have to be loaded into memory


How do I upgrade the framework? Like I said, I have run those commands and on my Module Admin page it says version 13.0.137 is installed and up-to-date???

Also… Have I slipped onto an edge release? Or is this problem in the stable release? I downloaded the stable ISO, but perhaps I chose something incorrectly during setup?

Just run:

fwconsole ma upgrade framework

and everything should be restored.

I just couldn’t get the core framework upgraded no matter what I tried.

In the end I just reinstalled everything and it picked up the correct version during install.

Thanks, upgrading framework fixed, although i had some exception errors showing up and a “Cannot Connect to Asterisk” problem. modules are updated now but needs more work. fwconsole chown, reload again, i think i am up and running.