Multiple issues with vm and parking apps from digium phones

have a few clients reporting in today that they cannot retrieve visual voicemail or park calls on digium phones (sangoma D series).

when trying to park a call the client reports it does nothing and the screen says " Request failed, please try again"

I’ve set up a test D62 phone in my office, connected it to their phone system using EPM and the built in OpenVPN.

When I place a test call and then try to park it the screen just show’s “loading” and then eventually goes back to the main screen.

If I try to access the parking lot when the phone is idle, same issue.

I specifically set up a test phone from my office and used the OpenVPN connection to eliminate it being an issue on their network/firewall etc…

Likewise when the phone is idle and I try to retrieve VM, it just stalls on the “loading” screen and eventually goes back to the main idle screen of the phone. This happens both at the client location and on my test phone from my office.

Anyone have any ideas?

downgraded DPMA module from 3.6.5 to 3.6.3. Didn’t help.

downgraded FreePBX Framework to and both voicemail and parking are working again.

If you upgrade, does it break again. If this is the fix and going back and forth fixes and breaks it respectively you probably want to file a bug report at

just did another client but only went back to which is one step back. This too fixed it so I tried and re-updated. Fix seems to stick… Weird.

Ok, apparently that wasn’t the fix… Half the phones work now and half don’t. The one’s that don’t work all exhibit the same behavior, when trying to view the parking lot or park a call “Request Failed, please try again”

downgraded the phone apps module this time… that seems to have fixed the other phones… waiting on full confirmation from the client.

Question: being that these are all D65/D62 phones, should I have “Use DPMA Apps” set to enabled in the EPM profile? It’s disabled by default.

Please note your phone apps version and note a security released just happened

If the fixing it requires you to go to an exploitable version you probably don’t want to do that.

So rolling back to should be safe?

You can use DPMA Apps which is independent of RestApps. Refer to EPM-DPMA for Digium Phones - PBX GUI - Documentation or EPM- DPMA Apps - PBX GUI - Documentation

If somehow your apps stopped working on the latest restapps then suggest you to open support ticket to debug further.

I’ve had multiple sites reporting issues after upgrading phone apps to 15.0.20

I’ve just had another client with the same issues, on D series phones parking and visual voicemail does not work. Downgrade to phone apps fixes the issue. I’ve entered a bug report.

Follow up:

So again I’m getting complaints this morning from some clients that had the automatic updates for critical security issues turned on.

Over the weekend they were updated to Phone Apps 15.0.20 and the phone apps on D series phones stopped working. I down graded phone apps to and after applying the change, FreePBX Framework reports is installed and needs to be upgraded to (the same version).

At this point phone apps still does not work. So I upgrade phone apps back to 15.0.20, then apply. Then re-install FreePBX Framework to and apply and the apps work again.