Multicast Paging Not Working (Commercial Module)

I have Paging Pro activated on FreePBX and I am using a group of Sangoma S500 phones to test.

I want to make use of multicast for paging but so far my testing is failing.

To test I have done the following:

  • setup a page group with an extension of 40001
    – added 3 extension (1060,1061,1062) to the device list within this group
    – selected force valet
    – added a multicast address of in the RTP Multicast section.
  • configured the S500 phone template within endpoint manager to enable multicast for this group of phones and entered the address
  • added a speed dial button to the phone template to dial 40001
  • Saved and updated phones

At this point I tested from the phones. I pressed the speed dial button, said something and hung up. All three phones then rang, auto answered and played the message. This worked as I expected but I wanted to confirm the traffic was multicast. I started a packet capture on the network and repeated the test. I then reviewed the packet capture and could see no multicast. Instead the PBX server made three calls. Screenshot below from packet capture:

NOTE: SCREENSHOT HAS A TYPO IN THE KEY (should be phone 1, 2 and 3)

I then tested to confirm Multicasting is actually working. I created a new button on the phone template and selected Multicast Page with the address: Saved and updated phones.

Tested pressing the multicast button on the phone and this instantly rang (no valet) the other two phones and they auto answered and could hear what ever I was saying (no recorded message). I performed another packet capture and could see that the traffic was indeed multicasted. See screenshot below:

The final test I did was to remove the phones from the list of devices within the 40001 page group. I thought maybe if the group had no devices but included a multicast address it would work. When I tested dialing the 40001 extension it let me record a message but when I hung up the other phones did not receive the message.

System info:
Current Asterisk Version: 13.19.1
PBX Firmware:12.7.4-1803-1.sng7
PBX Service Pack:

S500 phone firmware (IMG):

Paging module versions
Paging Pro
Paging and Intercom

Registered Commercial Modules
Call Recording Report Expiration Date 2043-03-16 (Free Updates until 2019-03-16)
Paging Pro Expiration Date 2043-03-16 (Free Updates until 2019-03-16)
Sys Admin Expiration Date 2043-03-16
Voicemail Reports Expiration Date 2043-03-16 (Free Updates until 2019-03-16)
Fax Pro Expiration Date 2043-03-23 (Free Updates until 2019-03-23)
VQ Plus Expiration Date 2043-03-16 (Free Updates until 2019-03-16)

Can you try it without Valet? Also dumb question but the PBX is local to your phones right on the same subnet?

Hi Tony

I have tested without Valet and I get the same results. (Creates 3 calls instead of multicasting)

The PBX is not on the same subnet. Its at a remote office and the phones connect to it via site to site VPN.

Does the PBX need to be on the same subnet? I thought it was just the phones that needed to be on the same subnet for multicast to work? Multicast worked fine with the “Multicast Paging” button but I did not get the benefits of the Page Group such as announcements, etc.

Yes Multicast can only work on the same subnet. That is the how multicast protocol works. If they are not on same subnet the PBX can not reach the phone for multicast. The reason the multi cast button on the phone works is because all the phones are on the same subnet and it has nothing to do with Asterisk.

Some people have had luck routing multicast through VPN on routers you can google that but its not a Asterisk or FreePBX thing as its part of network setup for Multicasting but I know alot of routers wont do it.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.