Moving to next extension in queue even when available

Hello all!

This is probably something simple, but I can’t get it to work. FreePBX v16 with SangomaPhone.

There are 2 queues with 3 extensions in each. The idea is to have the call come into the first queue, and after 1 minute (for example), if no one is available, go to the second queue. This works fine when all 3 extensions in the first queue are on a call or are marked as DnD. However, it doesn’t work if an extension is available, but simply doesn’t pick up for a while.

I’ve set extensions “initial ring time” to 20 and “ring time” to 0; “no answer” is set to “terminate call” with “busy”. From this, I would assume that if it’s not answered in 20 seconds, it would consider the extension as busy and move onto the next one in the queue. But in practice the call keeps ringing this extension past the 20 seconds.

I haven’t explored auto-pause, but seeing there’s no apparent auto-unpause, it won’t work, since people will forget to unpause.

Is the above the correct approach for this scenario?


Would using “optional destinations” and setting them to terminate the call, help in the above scenario?

In Queue 1

  • Set Failover Destination to Queue 2
  • On Timing and Options Tab:
    • Set Max Wait Time to 60 Seconds
    • Set Agent Time Out to 20 Seconds

Doing the above should ring each available agent in queue 1 for 20 seconds and then after 60 seconds of being in queue 1 it will move the caller to queue 2.

You may also want to review the join empty options for queue 1 as well. For instance, if all 3 agents in queue 1 are on the phone, if you want a 4th call to immediately go to queue 2 without waiting 60 seconds on hold in queue 1 waiting for a a queue 1 agent to become available, then you may want to look at the Ultra Strict Join Empty option to prevent this.


I would also probably set the Agent Timeout Reset option to No.

Thank you. That’s pretty much exactly as what I’ve set up and it doesn’t work. The available agent has her phone ringing for the full minute, not 20 seconds and then it moves to the second queue.

In queue 1, I have Join Empty set to Yes, so callers will wait in the queue, but I have Leave Empty set to No. Could that be keeping that available agent ringing for the whole duration?

No I don’t think the leave empty should impact this behavior. Can you post a screenshot of the General Settings, Queue Agents, Timing, and Capacity tabs?

That might help us better determine what’s happening here.

Thank you. I tried it, and it didn’t really change anything, as you said.

Please find attached screenshots - maybe they’ll shed some light.

Does this look like a bug that needs to be reported or it’s a mis-configuration issue?

After more testing, I found out that it works as intended when using rrmemory strategy, so leastrecent doesn’t work (haven’t tried others), but at least one strategy works. Is this definitely a bug then, or is that intended behavior for that ringing strategy?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.