I have the following set up:

Alcatel —> 2901 (3xxx) <-----------------Fibre IP LINK---------------> 2901 (in Data Centre) ------->Primary IP PBX

I have ironed them all out apart from 1 and I am completly stumped - I would really appreciate some help.


Alcatel handset rings an IP handset - Call established. Alcatel handset wants to transfer call to another Alcatel handset so they enter number. At this point the Asterisk MOH kicks in and plays to the IP handset. Alcatel handset puts call through and hangs up but MOH does not stop on IP handset however there is one way audio. The Alcatel handset can hear the IP handset but the IP handset is still listning to MOH.

I don’t understand how the Alcatel is able to initiate the Asterisk MOH rather than it’s own.

My question is basically - Is there a way to stop the Alcatel from initiating MOH on Asterisk?

How is the Alcatel connected to the Asterisk? PRI or analog?/ Either way it is generating hook flash event for trunk 2 trunk xfer

It’s connected via PRI E1 using QSIG with Alcatel ABC-F.

Can I block this hook flash on the trunk?

EDIT: Never heard of hook flash before and investigating I see there are some commands to enable support on the Cisco routers. I’ll investigate this next week.


I have investigated and still no joy. I forgot to mention that there are 2 2901 Cisco routers between the PBX and Asterisk which I am convinced are the cause of the issue but I can’t for the life of me suss it out (i’m not getting any help on the Cisco forums either)

Any help would be greatly appreciated!


Just to let you know that I solved my problem

I found the solution on an old Digium DAHDI bug tracker post from 2008.

Enter the following in chan_dahdi.conf


The Alcatel was sending a remote hold and remote retrieve. The above blocks this request.

I can’t find this fix or see it documented as an available option anywhere on the internet so hopefully this post will help out people with the same problem in the future.