Modules Endpoint Whoops error

I ran all my updates last night and now I get this error any time I try to add a phone


Please paste the entire error. A screenshot is fine, if you can’t paste the text, just as long as it’s readable. (If you’re on windows, select your browser then push alt-printscreen. Then come here, and click ‘reply’ and then paste in the reply box, either with control-v, or right click.

Like this!

It seems like any time I do anything in end point manager the phone doesn’t recognize any changes even after saving configs and rebooting the phone. I have to manually logon to the phone to get it to register. Not fun for 50 phones.

Similar thread:

I’d check to make sure your modules are all up to date, and maybe go into an extension and just click ‘save’ without changing anything. If that doesn’t fix it, try a ‘fwconsole reload’. I think I know what the problem is, but I can’t see how it happened!

I assume I run this in the cli command window. I get No such command ‘fwconsole reload’ (type ‘core show help fwconsole reload’ for other possible commands)

I think you tried to run that inside asterisk? No, just log into your machine as root, and run ‘fwconsole reload’.

that worked! But endpoint is still not registering the phone wihtout having to login to each IP address for each phone. I bought endpoint so I could make group changes. The only thing I can actually get it to do is reboot the phone

What exactly do you mean by that? Log into the phone’s web browser? Log in via the screen? What exactly are you doing and changing to make it work?

I have to logon to the URL of the phone http://192.168.x.x. In this case a Sangoma S500. I have to manually enter the sip server, user ids, and passwords, labels. It’s a pain that I thought endpoint would handle? Endpoint is not setting anything.

Or if you can’t configure your DHCP server, you can use the Provisioning Server, which is linked in that article, too.

man your good! worked like a champ. Last question. My button labels seem to only a small amount of characters. Do you know how to increase this so it doesn’t get cut off? Also what is the best way to upload the background image? Keeps saying invalid image

You’ve reached the end of my knowledge, sorry. I don’t know either of them 8-\


haha. I’ll do some research. thanks for your help man.