Modules cannot be loaded in distro


I am new to the forum and to freepx, asterisk too.

I installed the distro to a digium 110p card as below:

centos SHMZ release 6.5 (Final)
Linux 2.6.32-431.el6.i686 #1 SMP Fri Nov 22 00:26:36 UTC 2013 i686 i686 i386 GNU/Linux
Asterisk 11.7.0
DAHDI Version: Echo Canceller: OSLEC
PBX Firmware: 5.211.65-6
PBX Service Pack:

I use this system to interface a ss7 small switch with voip trunks
I configured chan_dahdi.conf and system.conf as using, but is not loaded, and this is working !? I do not find it from command " module show like libss7", while

localhost*CLI> module show like chan_dahdi
Module Description Use Count DAHDI Telephony Driver w/PRI & SS7 & MFC 1
1 modules loaded

It seems that ss7 is emulated from dahdi only.
Anyway, the point is that I like to try really libss7 and chan_ss7

After the distro is installed, I can find in a far directory, and copied it to directory of modules of the asterisk with the same owner and permission as other modules and after the load command I have:

Command ‘module load’ failed.
[2014-05-16 11:51:55] WARNING[11573]: loader.c:436 load_dynamic_module: Module ‘’ did not register itself during load
[2014-05-16 11:51:55] WARNING[11573]: loader.c:902 load_resource: Module ‘’ could not be loaded.

The was not in the system after the distro was installed so, I downloaded the source trunk, the “asterisk11-11.7.0-36_centos6.src.rpm” file from which I thought this asterisk is generated, unzipped it to usr/local/src and I followed the steps in .spec file for configure and make of this asterisk(not make install), and then I make the chan_ss7 from the trunk using this asterisk source, and obtained the that I copied to asterisk module directory with the same owner and permissions like all other modules and after reload of asterisk and tried loading of the module I got:

Unable to load module
Command ‘module load’ failed.
[2014-05-16 11:52:33] WARNING[11573]: loader.c:824 inspect_module: Module ‘’ was not compiled with the same compile-time options as this version of Asterisk.
[2014-05-16 11:52:33] WARNING[11573]: loader.c:825 inspect_module: Module ‘’ will not be initialized as it may cause instability.
[2014-05-16 11:52:33] WARNING[11573]: loader.c:915 load_resource: Module ‘’ could not be loaded.

I identified the identical version of asterisk in distro, I downloaded its source, I used the rigorously the same configure options found in the .spec file in source rpm, I tried different subversions of asterisk, but the problem persists.

Can anyone help me ?
how can I find what feature in configure is enabled or disabled wrongly ?

thanks in advance

If you use ss7 you should probably recompile all of asterisk,

from the source directory:-

make menuselect

make sure you have all selections you want and all dependencies are met if not get them installed and start over

make install

it won’t break anything.

Thank you dicko for the help.

I am afraid to change asterisk in distro may be problems, what do you think ?
Chan_ss7 requires a builded source asterisk to put to its makefile, for a success build. This is the reason that I downloaded the source of asterisk and build it.
libss7 does NOT need a asterisk source folder.

In all cases, my intention was to keep the executable asterisk of distro, thinking that changing it may cause instability in distro freepbx system.

Do you think to replace asterisk ?


Well, we are in “general help” and I can’t speak for whether there would be “any problems” in recompiling asterisk in “distro” I do know that it would be greatly discouraged and you would no longer have their support, but a working system is just a few layers of software , first off, the OS and then a web server php and an rdbms , then Asterisk, then any extra channel drivers you need for your hardware/phone lines, finally FreePBX. Although not for a complete newbie the process is well documented and very straight forward.

The various “Distros” wrap all that up into a somewhat generic package that will work successfully on the vast majority of situations but they would never be able to “cover every base”, You unfortunately are in that small minority, possibly you could find a distro that includes ss7, you could ask and wait for your current distro to add it, you could build your own system, or pragmatically you could just “suck it and see”

As each layer of software requires the underlying layers to be there and supportive of what you try and do, then some-one and, it could be you , would need to ensure that libss7-dev was available to asterisk before it is compiled.

If your distro includes all the necessary tools to build software a simple

yum install libss7

before compiling asterisk against a working dahdi , if it doesn’t then I think your best solution would be to use an alternative path.