Module: FreePBX Framework, File: /usr/local/sbin/amportal altered (You may need to run "amportal chown")

Just update module and receiver error . Followed recommended fix -
amportal chown
amportal a ma refreshsignatures
amportal a reload
Did not clear error

I have the same thing after updating modules.

It resolved after -

amportal chown
amportal a r
1 Like

running these commands via SSH:

amportal a ma upgradeall
asterisk -rx 'dialplan reload’
asterisk -rx ‘manager reload’

Then log into the web interface and click the Apply Config button
That cleared error

Those commands have nothing to do with FreePBX.

Thanks, brk. Your suggestion resolved for me as well!

BRK’s solution worked for me as well. Perhaps that warning message should be changed to:

“If you just updated FreePBX, you’ll need to run ‘amportal chown’ and then ‘amportal a r’ to clear this message. If you did not just update FreePBX, your system may have been compromised.”

1 Like

this solved my problem, when amportal chown on its own would not.