Mitel VLAN Settings Greyed Out

I have 20 Aastra/Mitel 6865i phones. When i go into the network settings to configure the VLAN options i can’t check the box for “VLAN Enable”. Also the VLAN ID is grayed out and won’t let me change it.

I add the following to the aastra.cfg and when im on the phone i can see the server config has those items listed.
I really just want to do DHCP option 132 and 133 which I have done for SNOM phones and it works great.

#Enable VLANS
tagging enabled: 1
VLAN id: 20

Am i missing something simple here?

This is more of a Mitel Support issue and not at all a FreePBX issue.
… but as a fellow Mitel customer I’ll try to help.

What I would try doing is backtrack and take out what you put in aastra.cfg, reboot the phone, then go to the Web Admin of the 6865i, change the VLAN settings to what you want from the web GUI there:

Then under Troubleshooting > Support Information > Get local.cfg
Find the section for VLANs in that .cfg and copy that part into the aastra.cfg to deploy to your phones (or if using the EPM in FreePBX add this to the Basefile Edit for aastra.cfg).

Hi Adolfoc, appreciate the reply and help!

So i actually reset the phone back to factory defaults just like i plugged it in for the first time. Even with no configuration being pulled to the device for some reason it doesn’t let me check the “Enable” checkbox.

I have some older Aastra 57i phones and i seem to be able to check it on those devices. Im pretty stumped!

what happens when you set the DHCP Download Option from (default) “Any” to “Disabled”?

what firmware version is that 6865i?

Yeah same thing. Firmware is

Could a networking switch be passing down a VLAN config?
If not, eeeeh… at this point I would reach out to Mitel or your supplier… I have not experienced this before.

Mitel Support for Open Devices North America: 1-800-574-1611
Hours of Operation are Monday to Friday 8 AM to 6 PM central time.
or if it’s non-critical and can wait a couple days then they have a ticketing system: