Mitel 5220 *ERROR NO REG*

Hello there,
I have been using trixbox @ home as our SOHO PBX for a while and now my friend is looking for an alternate solution for his business because his VOIP provider is giving him pretty bad service. I offer to help him in migrating his Mitel 5220 to trixbox.

Since I have never used Mitel 5220 before, I use one of his phone for testing.

So far, I upgrade the firmware from 3xxx to 4 then 5 then 6xx. Using the phone url, I change the user and the server configuration. I can call other phone from the Mitel but I cannot call the Mitel and the Mitel display this message in the screen : ERROR NO REG

Can someone give me some hints on what might be the the issue.

Eustache D

Someone please give me a clue …


The support here is for FreePBX and when many of us others know something, we try and answer other peoples questions but for things like phone support it’s a shot in the dark kind of thing some times.

You have several issues going against you at this point. You are using a very, very old version of things where support has been discontinued. It is possible that the phone might have a sub option or requirement that, that old of a version of asterisk can’t support.

Your first issue should be can that version of asterisk support that phone? That is a asterisk and phone manufacture issue not a FreePBX issue.

So some ideas:

Have you used google today?
Have you tried Mitel’s support pages? as you seem to be missing some setup parameter that it is looking for.

I’m sure if somebody who has worked with those phones see’s your post they will respond. If you are in a hurry the other choice is to pay for some support, but they might need to get a phone in hand to figure it out.