Missing phone from Endpoint -need next step in troubleshooting

One of our Sangoma phones vanished from Extension Mapping in the middle of the day today. I’ve been unable to get it back. There’s nothing showing on the firewall as blocked. As near as I can tell, Fail2ban isn’t blocking it. Nothing was changed on the FreePBX prior it it’s loss (since last week when I did a module update but the phone worked after that).

I can ping the phone from the remote router. I can ping the FreePBX IP from the remote router. But the S500 phone will not connect to FreePBX. I’ve been trying for hours now. I’ve rebooted everything, including FreePBX. No success.

FreePBX 14.0.5.25 Asterisk 13.22.0

What’s the next step in troubleshooting this problem? I’m not sure where to turn next.

Still missing this morning. If it’s not blocked in Fail2ban, or the Firewall, where else might it be getting blocked?

It’s been 24 hours now which should have cleared any firewall blocks. Still nothing. My remote user has been unable to work for an entire day now over this issue. I could really use some suggestions on how to get her phone working.

Did you check your Sangoma portal for the redirect service?

I have no idea why the poll date is so old as both of these phones are online and active. But someplace to look.

In Extensions>Other does it still show the MAC address in the Endpoint settings?

This phone has been working for well over a year. I did look in the portal to see if the counter incremented when the phone reboots. It does not. But I’ve been told that it wouldn’t because it’s not re-downloading the configuration. Once it’s in the phone, it doesn’t hit the portal again. And that’s why the poll date would be so old… because it’s not re-polling each time.

Then default it? That should force the issue.

Every time I’ve defaulted a Sagoma phone I’ve had to bring it into the office, let it load it’s provisions, and then send it back out again. I’ve had support on the phone with me for days in a row trying to get Sangoma phones to work and that’s what we’ve had to do every time we default one.

I"m not sure where you’re looking. If I go into Endpoint Manager->Extension Mapping it does have the MAC address listed for that extension. The IP address/Status line is empty.

This is an issue.

If you cannot provision a phone remotely, then that is your problem. The phone cannot reach your PBX. to get the configuration.

Are you certain you have your EPM setup right to match your network design?

Applications>Extensions>Other

I wasn’t certain. That’s why I’d called support the first time. They checked everything and it was right, but still couldn’t get it to connect. They did a bunch of trial and error changes trying to find what was wrong. It went on for days, literally. We finally did get them to register as long as they were connected in our local network. Once they’d been connected locally we could then send them out in the world and they’d connect fine. We were told that was the normal way of provisioning the phones. And that’s what I did on the other phones I had to provision. Any time I’ve had to default one, I’ve had to bring it to our network to get it working.

In the end they have the IP/FQDN address as a local LAN IP address. Both “Last poll from” IPs are my local WAN IP.

On the phone issue we’re working on now, that phone has been in place for a year. We didn’t make any changes. The remote IP is still the same. It just dropped off yesterday morning for some unknown reason. I thought maybe the cable had gone back but it answers pings correctly so the cable shouldn’t be the issue.

I’ve rebooted the phone dozens of times. I even rebooted the entire PBX. But it doesn’t connect. I don’t see it listed in Fail2ban. And the Responsive Firewall says it has no entries.

Ok. I see where you are. I was trying to find the “Other” menu under Applications/Extensions and there is none. But you’re going into that specific extension menu to the “other” tab. I’m caught up with you now. Sorry about that.

Yes, the MAC address is listed correctly there.

1 Like

Since we didn’t default the phone the configuration is still loaded in it.

You should be able to navigate to your PBX from the user’s location in a web browser and get your configuration.

https://username:[email protected]:1443/cfg0500.xml

The EPM Global screen gives you the info. Redacted in this screenshot…

If you do not see this, then your have something wrong with connectivity.

Was not able to open the page. Error saying the server took too long. That fits with some sort of firewall problem. I just can’t figure out where it’s blocked.

Make sure all the ports and such are right in FreePBX first.

And then that the FreePBX firewall is setup to accept them.

If you don’t want to open it to the internet at large, whitelist the user’s IP.

If after that, it does not work, then look at your network firewall.
You will need to port forward the specific ports.

Some of my ports don’t match yours, for example the Provisioning port. But the port listed in the PBX does match the port listed in the Sangoma portal. I did check the provisioning port to make sure it matches with the URL you gave me earlier and it does.

And my services don’t match, but nothing looks out of order. I’m not running Zulu UC for example.

I do have her IP address listed as a Trusted entry in the firewall already.

You can verify that the PBX is answering correctly by trying to navigate to the same thing inside your network, using the internal IP.

If you get it there, then it is your network edge router that is blocking things.

If I enter your string https://username:[email protected]:1443/cfg0500.xml I get an Authentication Required windows along with a warning that the connection is not secure. If I enter the user name and password into the box that appears the box just reappears.

If I enter the user name and password for the System Admin, I do get past the screen (when accessing locally). I never get the prompt to log in from the remote location.