Missing CallerID on Outbound calls after upgrade to Asterisk 11.x

Has anyone else seen this? It works fine on Asterisk 10.x, but if I upgrade to Asterisk 11.x I lose outbound CallerID (Number) - Thought it might be an issue with FreePBX 2.10, so I updated to the Beta 2.11 and same thing - searched the forums and didn’t see anyone else posting this. This is with Level(3) SIP Trunks.


Looking at this, it says that Asterisk 11 support was one of the milestones - weird.

The problem went away in Asterisk - Applied it tonight and you get caller ID on outbound now.



That’s really odd, are these L3 LI trunks? Were you effected by Level 3’s giant ass DoS issue today? Our /16 BGP worked like a treat but the /24’s wouldn’t budge so we had a little outage. PITA

Well, I thought the problem was solved, but in testing this morning, it’s still there - It’s a problem with FreePBX 2.11 and Asterisk 11.x - I have a weird trunking setup with Level(3) - We have a box at our CoLo and a failover box at our Office - I upgraded the Internal office box to Asterisk 11.3 last night but I also upgraded the failover Office box also - the Failover box is still running FreePBX 2.10 and with Asterisk 11.3 it is working fine - my Office box, that goes out through it that is running FreePBX 2.11 and Asterisk 11.3 (well it was, I dropped back to blanks the caller ID.


And no, we have not had any affect from the DDoS - Do you have any news links to it?


No news links, I found out from one of their techs at the colo last night.

Have you tried just turning off RPID updates? L3 probably doesn’t know what to do with them.

Same for me…

CallerID on outgoing SIP trunk works fine when switched to 10.12.0, switch to 11.3 and it stops working. Looking in console and I see the CID being set, but doesn’t make it through the trunk. Running 10.12.0 for now.

Any suggestions greatly appreciated!

Distro: 3.211.63-8
Asterisk: 11.3

FWIW, we had CallerID issues after restoring a backup to a standby machine, which was resolved by going through each of the users (we use User/Device), changing something (doesn’t really matter what just so the “Submit” button become active), click “Submit” and then applying.
BTW, when we had this same problem in the past, we did this process on a single user and it resolved CallerID for all of them. YMMV.