Mirrors/repos down again?


#1

I did an update for v14, with intention of doing an upgrade to v15 around midnight my time (now 14 hours ago).

Now I am getting , though ping is getting a response. to mirror.freepbx.org, mirror1.freepbx.org, and mirror2.freepbx.org

Unable to connect to the remote mirror servers

FreePBX is not able to connect to the remote mirror servers. An upgrade can not happen without being able to talk to these servers

Even running: fwconsole ma listonline returns:

±--------------------±-----------±----------------------------------±-----------+
| Module | Version | Status | License |
±--------------------±-----------±----------------------------------±-----------+
| accountcodepreserve | 13.0.2.2 | Enabled; Not available online | GPLv2 |
| amd | 13.0.3 | Enabled; Not available online | GPLv3+ |
| announcement | 13.0.7.8 | Enabled; Not available online | GPLv3+ |
| asterisk-cli | 14.0.2 | Enabled; Not available online | GPLv3+ |
| asteriskinfo | 13.0.7.2 | Enabled; Not available online | GPLv3+ |


[BUG] framework 14.0.16.4
(Jared Busch) #2

None of the servers I run have that issue, but you might go through this thread from a couple days ago.


(Jared Busch) #3

That said, I just had this happen mid update…

image


image

And now I do have a problem…
image

image

[jbusch@pbx ~]$ sudo fwconsole ma listonline
No repos specified, using: [standard,commercial] from last GUI settings

+----------------------+------------+-------------------------------+------------+
| Module               | Version    | Status                        | License    |
+----------------------+------------+-------------------------------+------------+
| accountcodepreserve  | 13.0.2.2   | Enabled; Not available online | GPLv2      |
| amd                  | 15.0.3     | Enabled; Not available online | GPLv3+     |
| announcement         | 15.0.3.11  | Enabled; Not available online | GPLv3+     |
| api                  | 15.0.3.8   | Enabled; Not available online | AGPLv3+    |
| arimanager           | 15.0.3.9   | Enabled; Not available online | GPLv3+     |
| asterisk-cli         | 14.0.3     | Enabled; Not available online | GPLv3+     |
| asteriskinfo         | 15.0.12    | Enabled; Not available online | GPLv3+     |
| backup               | 15.0.10.43 | Enabled; Not available online | GPLv3+     |
| blacklist            | 15.0.2.12  | Enabled; Not available online | GPLv3+     |
| builtin              |            | Enabled; Not available online |            |
| bulkhandler          | 13.0.23    | Enabled; Not available online | GPLv3+     |
| calendar             | 15.0.4.21  | Enabled; Not available online | GPLv3+     |
| callback             | 15.0.11    | Enabled; Not available online | GPLv3+     |
| callforward          | 15.0.13    | Enabled; Not available online | AGPLv3+    |
| callrecording        | 15.0.7.13  | Enabled; Not available online | AGPLv3+    |
| callwaiting          | 15.0.4.4   | Enabled; Not available online | GPLv3+     |
| campon               | 13.0.4.1   | Enabled; Not available online | GPLv3+     |
| cdr                  | 15.0.17.6  | Enabled; Not available online | GPLv3+     |
| cel                  | 15.0.15.11 | Enabled; Not available online | GPLv3+     |
| certman              | 15.0.37    | Enabled; Not available online | AGPLv3+    |
| cidlookup            | 15.0.20    | Enabled; Not available online | GPLv3+     |
| conferences          | 15.0.7.6   | Enabled; Not available online | GPLv3+     |
| configedit           | 13.0.7.3   | Enabled; Not available online | AGPLv3+    |
| contactmanager       | 15.0.8.30  | Enabled; Not available online | GPLv3+     |
| core                 | 15.0.12.40 | Enabled; Not available online | GPLv3+     |
| customappsreg        | 15.0.14    | Enabled; Not available online | GPLv3+     |
| dahdiconfig          | 15.0.5.7   | Enabled; Not available online | GPLv3+     |
| dashboard            | 15.0.7     | Enabled; Not available online | AGPLv3+    |
| daynight             | 15.0.12    | Enabled; Not available online | GPLv3+     |
| dictate              | 15.0.7     | Enabled; Not available online | GPLv3+     |
| digiumaddoninstaller | 13.0.1.1   | Enabled; Not available online | GPLv2      |
| directory            | 15.0.18    | Enabled; Not available online | GPLv3+     |
| disa                 | 15.0.4.9   | Enabled; Not available online | AGPLv3+    |
| donotdisturb         | 15.0.8     | Enabled; Not available online | GPLv3+     |
| fax                  | 15.0.21    | Enabled; Not available online | GPLv3+     |
| featurecodeadmin     | 13.0.6.10  | Enabled; Not available online | GPLv3+     |
| filestore            | 15.0.3.12  | Enabled; Not available online | AGPLv3     |
| findmefollow         | 15.0.24    | Enabled; Not available online | GPLv3+     |
| firewall             | 15.0.8.4   | Enabled; Not available online | AGPLv3+    |
| framework            | 15.0.17.17 | Enabled; Not available online | GPLv2+     |
| fw_langpacks         | 14.0.1     | Enabled; Not available online | GPLv3+     |
| iaxsettings          | 15.0.8     | Enabled; Not available online | AGPLv3     |
| infoservices         | 15.0.3     | Enabled; Not available online | GPLv2+     |
| irc                  | 13.0.1     | Enabled; Not available online | GPLv3+     |
| ivr                  | 15.0.29    | Enabled; Not available online | GPLv3+     |
| languages            | 15.0.12    | Enabled; Not available online | GPLv3+     |
| logfiles             | 15.0.14    | Enabled; Not available online | GPLv3+     |
| manager              | 15.0.10    | Enabled; Not available online | GPLv2+     |
| miscapps             | 15.0.10    | Enabled; Not available online | GPLv3+     |
| miscdests            | 15.0.2.12  | Enabled; Not available online | GPLv3+     |
| music                | 15.0.22    | Enabled; Not available online | GPLv3+     |
| outroutemsg          | 15.0.9     | Enabled; Not available online | GPLv3+     |
| paging               | 15.0.4.29  | Enabled; Not available online | GPLv3+     |
| parking              | 15.0.15.4  | Enabled; Not available online | GPLv3+     |
| pbdirectory          | 2.11.0.6   | Enabled; Not available online | GPLv3+     |
| phonebook            | 15.0.12    | Enabled; Not available online | GPLv3+     |
| pinsets              | 15.0.1.14  | Enabled; Not available online | GPLv3+     |
| pm2                  | 15.0.4     | Enabled; Not available online | AGPLv3+    |
| presencestate        | 15.0.10    | Enabled; Not available online | GPLv3+     |
| printextensions      | 13.0.3.4   | Enabled; Not available online | GPLv3+     |
| queueprio            | 15.0.10    | Enabled; Not available online | GPLv3+     |
| queues               | 15.0.26    | Enabled; Not available online | GPLv2+     |
| recordings           | 15.0.3.15  | Enabled; Not available online | GPLv3+     |
| ringgroups           | 15.0.11.10 | Enabled; Not available online | GPLv3+     |
| setcid               | 15.0.9     | Enabled; Not available online | GPLv3+     |
| sipsettings          | 15.0.6.31  | Enabled; Not available online | AGPLv3+    |
| soundlang            | 15.0.5.9   | Enabled; Not available online | GPLv3+     |
| speeddial            | 2.11.0.4   | Enabled; Not available online | GPLv3+     |
| superfecta           | 15.0.2.28  | Enabled; Not available online | GPLv2+     |
| sysadmin             | 15.0.21.6  | Enabled; Not available online | Commercial |
| timeconditions       | 15.0.15.8  | Enabled; Not available online | GPLv3+     |
| tts                  | 15.0.11    | Enabled; Not available online | GPLv3+     |
| ttsengines           | 15.0.4.7   | Enabled; Not available online | AGPLv3     |
| ucp                  | 15.0.6.26  | Enabled; Not available online | AGPLv3+    |
| userman              | 15.0.34    | Enabled; Not available online | AGPLv3+    |
| vmblast              | 15.0.11.6  | Enabled; Not available online | GPLv3+     |
| voicemail            | 15.0.18.20 | Enabled; Not available online | GPLv3+     |
| weakpasswords        | 13.0.2     | Enabled; Not available online | GPLv3+     |
| webrtc               | 15.0.9     | Enabled; Not available online | GPLv3+     |
| xmpp                 | 15.0.6.7   | Enabled; Not available online | AGPLv3     |
+----------------------+------------+-------------------------------+------------+

@lgaetz definitely something broken.

Here is the output in non-screenshot form.

[jbusch@pbx ~]$ sudo fwconsole ma upgradeall
No repos specified, using: [standard,commercial] from last GUI settings

Module(s) requiring upgrades: announcement, api, arimanager, asteriskinfo, backup, callback, callrecording, certman, conferences, contactmanager, core, dashboard, featurecodeadmin, framework, pinsets, queues, ringgroups, soundlang, sysadmin, timeconditions, userman, voicemail, webrtc
Upgrading module 'framework' from 15.0.17.12 to 15.0.17.17
Downloading module 'framework'
Processing framework
Downloading...
 16139664/16139664 [============================] 100%
Finished downloading
Extracting...Done
Download completed in 5 seconds
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications, cron_jobs...Done
Determined Asterisk version to be: 18.1.1
installing files to /var/www/html..done
installing files to /var/lib/asterisk/bin..done
installing files to /var/lib/asterisk/agi-bin..done
Checking for upgrades..
No further upgrades necessary
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/start_asterisk removed successfully
file/directory: /var/www/html/admin/modules/framework/install removed successfully
file/directory: /var/www/html/admin/modules/framework/installlib removed successfully
Compressing Framework CSS...Done
Setting Framework Version...Done
Running SQL cleanup...Done
Building Packaged Scripts...Done
Refreshing GPG Keys...Done
Generating CSS...Done
Module framework version 15.0.17.17 successfully installed
Updating Hooks...Done
Chowning directories...Done
Upgrading module 'core' from 15.0.12.40 to 15.0.12.44
Downloading module 'core'
The following error(s) occured:
 - Retrieved Module XML Was Empty
[jbusch@pbx ~]$ sudo fwconsole ma upgrade core
No repos specified, using: [standard,commercial] from last GUI settings

core does not exist online, unable to upgrade
Updating Hooks...Done
Chowning directories...Done
[jbusch@pbx ~]$ 

(Jared Busch) #4

I can directly install core current version, and I would assume any other.

[jbusch@pbx ~]$ sudo fwconsole ma downloadinstall core --tag 15.0.12.44
[sudo] password for jbusch: 
No repos specified, using: [standard,commercial] from last GUI settings

Starting module download from http://mirror1.freepbx.org/modules/packages/core/core-15.0.12.44.tgz.gpg ...
Processing 
Downloading...
 1162591/1162591 [============================] 100%
Finished downloading
Extracting...Done
Module http://mirror1.freepbx.org/modules/packages/core/core-15.0.12.44.tgz.gpg successfully downloaded
Updating tables trunks, pjsip, sip, dahdi, iax, indications_zonelist, devices, users, incoming, dahdichandids, outbound_route_patterns, outbound_route_sequence, outbound_route_trunks, outbound_routes, outbound_route_email, trunk_dialpatterns...Done
Adding emergencydevices table..Done
Migrating pickup groups to named pickup groups
Migrating call groups to named call groups
Checking for possibly invalid emergency caller id fields..none found
Migrating old media encryption values...done
Removing encoding on incoming routes alertinfo values...done
Generating CSS...Done
Module core version 15.0.12.44 successfully installed
Updating Hooks...Done
Chowning directories...Done
[jbusch@pbx ~]$ sudo fwconsole reload
Reload Started
Reload Complete
[jbusch@pbx ~]$

I downgraded framework back to where it was, but no dice.

[jbusch@pbx ~]$ sudo fwconsole ma downloadinstall framework --tag 15.0.17.12
No repos specified, using: [standard,commercial] from last GUI settings

Starting module download from http://mirror1.freepbx.org/modules/packages/framework/framework-15.0.17.12.tgz.gpg ...
Processing 
Downloading...
 16123610/16123610 [============================] 100%
Finished downloading
Extracting...Done
Module http://mirror1.freepbx.org/modules/packages/framework/framework-15.0.17.12.tgz.gpg successfully downloaded
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications, cron_jobs...Done
Determined Asterisk version to be: 18.1.1
installing files to /var/www/html..done
installing files to /var/lib/asterisk/bin..done
installing files to /var/lib/asterisk/agi-bin..done
Checking for upgrades..
No further upgrades necessary
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/start_asterisk removed successfully
file/directory: /var/www/html/admin/modules/framework/install removed successfully
file/directory: /var/www/html/admin/modules/framework/installlib removed successfully
Compressing Framework CSS...Done
Setting Framework Version...Done
Running SQL cleanup...Done
Building Packaged Scripts...Done
Refreshing GPG Keys...Done
Generating CSS...Done
Module framework version 15.0.17.12 successfully installed
Updating Hooks...Done
Chowning directories...Done
[jbusch@pbx ~]$ sudo fwconsole reload
Reload Started
Reload Complete
[jbusch@pbx ~]$
[jbusch@pbx ~]$ sudo fwconsole ma listonline
No repos specified, using: [standard,commercial] from last GUI settings

+----------------------+------------+-------------------------------+------------+
| Module               | Version    | Status                        | License    |
+----------------------+------------+-------------------------------+------------+
| accountcodepreserve  | 13.0.2.2   | Enabled; Not available online | GPLv2      |
| amd                  | 15.0.3     | Enabled; Not available online | GPLv3+     |
| announcement         | 15.0.3.11  | Enabled; Not available online | GPLv3+     |
| api                  | 15.0.3.8   | Enabled; Not available online | AGPLv3+    |
| arimanager           | 15.0.3.9   | Enabled; Not available online | GPLv3+     |
| asterisk-cli         | 14.0.3     | Enabled; Not available online | GPLv3+     |
| asteriskinfo         | 15.0.12    | Enabled; Not available online | GPLv3+     |
| backup               | 15.0.10.43 | Enabled; Not available online | GPLv3+     |
| blacklist            | 15.0.2.12  | Enabled; Not available online | GPLv3+     |
| builtin              |            | Enabled; Not available online |            |
| bulkhandler          | 13.0.23    | Enabled; Not available online | GPLv3+     |
| calendar             | 15.0.4.21  | Enabled; Not available online | GPLv3+     |
| callback             | 15.0.11    | Enabled; Not available online | GPLv3+     |
| callforward          | 15.0.13    | Enabled; Not available online | AGPLv3+    |
| callrecording        | 15.0.7.13  | Enabled; Not available online | AGPLv3+    |
| callwaiting          | 15.0.4.4   | Enabled; Not available online | GPLv3+     |
| campon               | 13.0.4.1   | Enabled; Not available online | GPLv3+     |
| cdr                  | 15.0.17.6  | Enabled; Not available online | GPLv3+     |
| cel                  | 15.0.15.11 | Enabled; Not available online | GPLv3+     |
| certman              | 15.0.37    | Enabled; Not available online | AGPLv3+    |
| cidlookup            | 15.0.20    | Enabled; Not available online | GPLv3+     |
| conferences          | 15.0.7.6   | Enabled; Not available online | GPLv3+     |
| configedit           | 13.0.7.3   | Enabled; Not available online | AGPLv3+    |
| contactmanager       | 15.0.8.30  | Enabled; Not available online | GPLv3+     |
| core                 | 15.0.12.44 | Enabled; Not available online | GPLv3+     |
| customappsreg        | 15.0.14    | Enabled; Not available online | GPLv3+     |
| dahdiconfig          | 15.0.5.7   | Enabled; Not available online | GPLv3+     |
| dashboard            | 15.0.7     | Enabled; Not available online | AGPLv3+    |
| daynight             | 15.0.12    | Enabled; Not available online | GPLv3+     |
| dictate              | 15.0.7     | Enabled; Not available online | GPLv3+     |
| digiumaddoninstaller | 13.0.1.1   | Enabled; Not available online | GPLv2      |
| directory            | 15.0.18    | Enabled; Not available online | GPLv3+     |
| disa                 | 15.0.4.9   | Enabled; Not available online | AGPLv3+    |
| donotdisturb         | 15.0.8     | Enabled; Not available online | GPLv3+     |
| fax                  | 15.0.21    | Enabled; Not available online | GPLv3+     |
| featurecodeadmin     | 13.0.6.10  | Enabled; Not available online | GPLv3+     |
| filestore            | 15.0.3.12  | Enabled; Not available online | AGPLv3     |
| findmefollow         | 15.0.24    | Enabled; Not available online | GPLv3+     |
| firewall             | 15.0.8.4   | Enabled; Not available online | AGPLv3+    |
| framework            | 15.0.17.12 | Enabled; Not available online | GPLv2+     |
| fw_langpacks         | 14.0.1     | Enabled; Not available online | GPLv3+     |
| iaxsettings          | 15.0.8     | Enabled; Not available online | AGPLv3     |
| infoservices         | 15.0.3     | Enabled; Not available online | GPLv2+     |
| irc                  | 13.0.1     | Enabled; Not available online | GPLv3+     |
| ivr                  | 15.0.29    | Enabled; Not available online | GPLv3+     |
| languages            | 15.0.12    | Enabled; Not available online | GPLv3+     |
| logfiles             | 15.0.14    | Enabled; Not available online | GPLv3+     |
| manager              | 15.0.10    | Enabled; Not available online | GPLv2+     |
| miscapps             | 15.0.10    | Enabled; Not available online | GPLv3+     |
| miscdests            | 15.0.2.12  | Enabled; Not available online | GPLv3+     |
| music                | 15.0.22    | Enabled; Not available online | GPLv3+     |
| outroutemsg          | 15.0.9     | Enabled; Not available online | GPLv3+     |
| paging               | 15.0.4.29  | Enabled; Not available online | GPLv3+     |
| parking              | 15.0.15.4  | Enabled; Not available online | GPLv3+     |
| pbdirectory          | 2.11.0.6   | Enabled; Not available online | GPLv3+     |
| phonebook            | 15.0.12    | Enabled; Not available online | GPLv3+     |
| pinsets              | 15.0.1.14  | Enabled; Not available online | GPLv3+     |
| pm2                  | 15.0.4     | Enabled; Not available online | AGPLv3+    |
| presencestate        | 15.0.10    | Enabled; Not available online | GPLv3+     |
| printextensions      | 13.0.3.4   | Enabled; Not available online | GPLv3+     |
| queueprio            | 15.0.10    | Enabled; Not available online | GPLv3+     |
| queues               | 15.0.26    | Enabled; Not available online | GPLv2+     |
| recordings           | 15.0.3.15  | Enabled; Not available online | GPLv3+     |
| ringgroups           | 15.0.11.10 | Enabled; Not available online | GPLv3+     |
| setcid               | 15.0.9     | Enabled; Not available online | GPLv3+     |
| sipsettings          | 15.0.6.31  | Enabled; Not available online | AGPLv3+    |
| soundlang            | 15.0.5.9   | Enabled; Not available online | GPLv3+     |
| speeddial            | 2.11.0.4   | Enabled; Not available online | GPLv3+     |
| superfecta           | 15.0.2.28  | Enabled; Not available online | GPLv2+     |
| sysadmin             | 15.0.21.6  | Enabled; Not available online | Commercial |
| timeconditions       | 15.0.15.8  | Enabled; Not available online | GPLv3+     |
| tts                  | 15.0.11    | Enabled; Not available online | GPLv3+     |
| ttsengines           | 15.0.4.7   | Enabled; Not available online | AGPLv3     |
| ucp                  | 15.0.6.26  | Enabled; Not available online | AGPLv3+    |
| userman              | 15.0.34    | Enabled; Not available online | AGPLv3+    |
| vmblast              | 15.0.11.6  | Enabled; Not available online | GPLv3+     |
| voicemail            | 15.0.18.20 | Enabled; Not available online | GPLv3+     |
| weakpasswords        | 13.0.2     | Enabled; Not available online | GPLv3+     |
| webrtc               | 15.0.9     | Enabled; Not available online | GPLv3+     |
| xmpp                 | 15.0.6.7   | Enabled; Not available online | AGPLv3     |
+----------------------+------------+-------------------------------+------------+
[jbusch@pbx ~]$

(Lorne Gaetz) #5

I’m not seeing any issues myself at this moment, but I’ve escalated these reports.


(Jared Busch) #6

Multiple other servers have no issues.

Prior to just now, I had not seen this either.

Edit: Enabled wget for module admin, no difference.


(Matthew Fredrickson) #7

This is very odd. I’ll see if someone can dig deeper as to what’s going on.

Matthew Fredrickson


(Jared Busch) #8

I just logged in to that server again and it is working now. I have made no changes.

Since that location has shutdown for the day, I was going to kick it and see if that resolved it, but it is already working.

Edit: Strike that… It upgraded framework from 15.0.17.12 to 15.0.17.21 and broke on core again.

[jbusch@pbx ~]$ sudo fwconsole ma upgradeall
No repos specified, using: [standard,commercial] from last GUI settings

Module(s) requiring upgrades: announcement, api, arimanager, asteriskinfo, backup, callback, callrecording, cdr, certman, conferences, contactmanager, core, dashboard, featurecodeadmin, firewall, framework, pinsets, queues, ringgroups, soundlang, sysadmin, timeconditions, userman, voicemail, webrtc
Upgrading module 'framework' from 15.0.17.12 to 15.0.17.21
Downloading module 'framework'
Processing framework
Downloading...
 16142301/16142301 [============================] 100%
Finished downloading
Extracting...Done
Download completed in 5 seconds
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications, cron_jobs...Done
Determined Asterisk version to be: 18.1.1
installing files to /var/www/html..done
installing files to /var/lib/asterisk/bin..done
installing files to /var/lib/asterisk/agi-bin..done
Checking for upgrades..
No further upgrades necessary
framework file install done, removing packages from module
file/directory: /var/www/html/admin/modules/framework/amp_conf removed successfully
file/directory: /var/www/html/admin/modules/framework/upgrades removed successfully
file/directory: /var/www/html/admin/modules/framework/start_asterisk removed successfully
file/directory: /var/www/html/admin/modules/framework/install removed successfully
file/directory: /var/www/html/admin/modules/framework/installlib removed successfully
Compressing Framework CSS...Done
Setting Framework Version...Done
Running SQL cleanup...Done
Building Packaged Scripts...Done
Refreshing GPG Keys...Done
Generating CSS...Done
Module framework version 15.0.17.21 successfully installed
Updating Hooks...Done
Chowning directories...Done
Upgrading module 'core' from 15.0.12.44 to 15.0.12.46
Downloading module 'core'
The following error(s) occured:
 - Retrieved Module XML Was Empty
[jbusch@pbx ~]$ 

MODULE_REPO is still legacy.
image

So I reset it to default
image

Reload, and they are now showing up again.
image

[jbusch@pbx ~]$ sudo fwconsole ma listonline
No repos specified, using: [standard,commercial] from last GUI settings

+----------------------+------------+----------------------------------------------+-------------+
| Module               | Version    | Status                                       | License     |
+----------------------+------------+----------------------------------------------+-------------+
| accountcodepreserve  | 13.0.2.2   | Enabled and up to date                       | GPLv2       |
| adv_recovery         |            | Not Installed (Available online: 15.0.17)    | Commercial  |
| amd                  | 15.0.3     | Enabled and up to date                       | GPLv3+      |
| announcement         | 15.0.3.11  | Online upgrade available (15.0.3.13)         | GPLv3+      |
| api                  | 15.0.3.8   | Online upgrade available (15.0.3.11)         | AGPLv3+     |
| areminder            |            | Not Installed (Available online: 15.0.14.24) | Commercial  |
| arimanager           | 15.0.3.9   | Online upgrade available (15.0.3.11)         | GPLv3+      |
| asterisk-cli         | 14.0.3     | Enabled and up to date                       | GPLv3+      |
| asteriskinfo         | 15.0.12    | Online upgrade available (15.0.14)           | GPLv3+      |
| backup               | 15.0.10.43 | Online upgrade available (15.0.10.48)        | GPLv3+      |
| blacklist            | 15.0.2.12  | Enabled and up to date                       | GPLv3+      |
| broadcast            |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| builtin              |            | Enabled; Not available online                |             |
| bulkhandler          | 13.0.23    | Enabled and up to date                       | GPLv3+      |
| calendar             | 15.0.4.21  | Enabled and up to date                       | GPLv3+      |
| callaccounting       |            | Not Installed (Available online: 15.0.24)    | Commercial+ |
| callback             | 15.0.11    | Online upgrade available (15.0.12)           | GPLv3+      |
| callerid             |            | Not Installed (Available online: 15.0.16)    | Commercial  |
| callforward          | 15.0.13    | Enabled and up to date                       | AGPLv3+     |
| calllimit            |            | Not Installed (Available online: 15.0.5.6)   | Commercial  |
| callrecording        | 15.0.7.13  | Online upgrade available (15.0.7.14)         | AGPLv3+     |
| callwaiting          | 15.0.4.4   | Enabled and up to date                       | GPLv3+      |
| campon               | 13.0.4.1   | Enabled; Not available online                | GPLv3+      |
| cdr                  | 15.0.17.6  | Online upgrade available (15.0.17.7)         | GPLv3+      |
| cel                  | 15.0.15.11 | Enabled and up to date                       | GPLv3+      |
| certman              | 15.0.37    | Online upgrade available (15.0.39)           | AGPLv3+     |
| cidlookup            | 15.0.20    | Enabled and up to date                       | GPLv3+      |
| conferences          | 15.0.7.6   | Online upgrade available (15.0.7.8)          | GPLv3+      |
| conferencespro       |            | Not Installed (Available online: 15.0.3.16)  | Commercial  |
| configedit           | 13.0.7.3   | Enabled and up to date                       | AGPLv3+     |
| contactmanager       | 15.0.8.30  | Online upgrade available (15.0.8.31)         | GPLv3+      |
| core                 | 15.0.12.44 | Online upgrade available (15.0.12.46)        | GPLv3+      |
| cos                  |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| customappsreg        | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| cxpanel              |            | Not Installed (Available online: 15.0.4)     | GPLv3       |
| dahdiconfig          | 15.0.5.7   | Enabled and up to date                       | GPLv3+      |
| dashboard            | 15.0.7     | Online upgrade available (15.0.9)            | AGPLv3+     |
| daynight             | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| dictate              | 15.0.7     | Enabled and up to date                       | GPLv3+      |
| digium_phones        |            | Not Installed (Available online: 15.0.3)     | GPLv2       |
| digiumaddoninstaller | 13.0.1.1   | Enabled and up to date                       | GPLv2       |
| directory            | 15.0.18    | Enabled and up to date                       | GPLv3+      |
| disa                 | 15.0.4.9   | Enabled and up to date                       | AGPLv3+     |
| donotdisturb         | 15.0.8     | Enabled and up to date                       | GPLv3+      |
| endpoint             |            | Not Installed (Available online: 15.0.39.33) | Commercial  |
| extensionroutes      |            | Not Installed (Available online: 15.0.8)     | Commercial  |
| fax                  | 15.0.21    | Enabled and up to date                       | GPLv3+      |
| faxpro               |            | Not Installed (Available online: 15.0.8.12)  | Commercial  |
| featurecodeadmin     | 13.0.6.10  | Online upgrade available (13.0.6.11)         | GPLv3+      |
| filestore            | 15.0.3.12  | Enabled and up to date                       | AGPLv3      |
| findmefollow         | 15.0.24    | Enabled and up to date                       | GPLv3+      |
| firewall             | 15.0.8.4   | Online upgrade available (15.0.8.9)          | AGPLv3+     |
| framework            | 15.0.17.21 | Enabled and up to date                       | GPLv2+      |
| fw_langpacks         | 14.0.1     | Enabled and up to date                       | GPLv3+      |
| hotelwakeup          |            | Not Installed (Available online: 15.0.5.4)   | GPLv2       |
| iaxsettings          | 15.0.8     | Enabled and up to date                       | AGPLv3      |
| infoservices         | 15.0.3     | Enabled and up to date                       | GPLv2+      |
| iotserver            |            | Not Installed (Available online: 15.0.2.6)   | Commercial  |
| irc                  | 13.0.1     | Enabled and up to date                       | GPLv3+      |
| ivr                  | 15.0.29    | Enabled and up to date                       | GPLv3+      |
| languages            | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| logfiles             | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| manager              | 15.0.10    | Enabled and up to date                       | GPLv2+      |
| miscapps             | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| miscdests            | 15.0.2.12  | Enabled and up to date                       | GPLv3+      |
| music                | 15.0.22    | Enabled and up to date                       | GPLv3+      |
| oracle_connector     |            | Not Installed (Available online: 15.0.2)     | Commercial  |
| outroutemsg          | 15.0.9     | Enabled and up to date                       | GPLv3+      |
| paging               | 15.0.4.29  | Enabled and up to date                       | GPLv3+      |
| pagingpro            |            | Not Installed (Available online: 15.0.1.21)  | Commercial  |
| parking              | 15.0.15.4  | Enabled and up to date                       | GPLv3+      |
| parkpro              |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| pbdirectory          | 2.11.0.6   | Enabled and up to date                       | GPLv3+      |
| phonebook            | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| pinsets              | 15.0.1.14  | Online upgrade available (15.0.1.15)         | GPLv3+      |
| pinsetspro           |            | Not Installed (Available online: 15.0.4)     | Commercial  |
| pm2                  | 15.0.4     | Enabled and up to date                       | AGPLv3+     |
| pms                  |            | Not Installed (Available online: 15.0.2.48)  | Commercial  |
| presencestate        | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| printextensions      | 13.0.3.4   | Enabled and up to date                       | GPLv3+      |
| queueprio            | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| queues               | 15.0.26    | Online upgrade available (15.0.27)           | GPLv2+      |
| queuestats           |            | Not Installed (Available online: 15.0.3.31)  | Commercial  |
| qxact_reports        |            | Not Installed (Available online: 15.0.3.28)  | Commercial  |
| recording_report     |            | Not Installed (Available online: 15.0.4.33)  | Commercial  |
| recordings           | 15.0.3.15  | Enabled and up to date                       | GPLv3+      |
| restapps             |            | Not Installed (Available online: 15.0.19.17) | Commercial  |
| ringgroups           | 15.0.11.10 | Online upgrade available (15.0.11.11)        | GPLv3+      |
| sangomaconnect       |            | Not Installed (Available online: 15.0.14)    | Commercial  |
| sangomacrm           |            | Not Installed (Available online: 15.0.21)    | Commercial  |
| setcid               | 15.0.9     | Enabled and up to date                       | GPLv3+      |
| sipsettings          | 15.0.6.31  | Enabled and up to date                       | AGPLv3+     |
| sipstation           |            | Not Installed (Available online: 15.0.5.17)  | Commercial  |
| sms                  |            | Not Installed (Available online: 15.0.15)    | Commercial  |
| soundlang            | 15.0.5.9   | Online upgrade available (15.0.5.10)         | GPLv3+      |
| speeddial            | 2.11.0.4   | Enabled and up to date                       | GPLv3+      |
| superfecta           | 15.0.2.28  | Newer than online version (15.0.2.23)        | GPLv2+      |
| sysadmin             | 15.0.21.6  | Online upgrade available (15.0.21.17)        | Commercial  |
| timeconditions       | 15.0.15.8  | Online upgrade available (15.0.15.9)         | GPLv3+      |
| tts                  | 15.0.11    | Enabled and up to date                       | GPLv3+      |
| ttsengines           | 15.0.4.7   | Enabled and up to date                       | AGPLv3      |
| ucp                  | 15.0.6.26  | Enabled and up to date                       | AGPLv3+     |
| userman              | 15.0.34    | Online upgrade available (15.0.35)           | AGPLv3+     |
| vega                 |            | Not Installed (Available online: 15.0.10)    | Commercial+ |
| vmblast              | 15.0.11.6  | Enabled and up to date                       | GPLv3+      |
| vmnotify             |            | Not Installed (Available online: 15.0.12)    | Commercial  |
| voicemail            | 15.0.18.20 | Online upgrade available (15.0.18.21)        | GPLv3+      |
| voicemail_report     |            | Not Installed (Available online: 15.0.6)     | Commercial  |
| vqplus               |            | Not Installed (Available online: 15.0.7.21)  | Commercial  |
| weakpasswords        | 13.0.2     | Enabled and up to date                       | GPLv3+      |
| webcallback          |            | Not Installed (Available online: 15.0.6.3)   | Commercial  |
| webrtc               | 15.0.9     | Online upgrade available (15.0.10)           | GPLv3+      |
| xmpp                 | 15.0.6.7   | Enabled and up to date                       | AGPLv3      |
| zulu                 |            | Not Installed (Available online: 15.0.58.9)  | Commercial  |
+----------------------+------------+----------------------------------------------+-------------+

#9

I did this also, and now able to get updates


(Jared Busch) #10

@mfredrickson
On another system, it also had the legacy URL in MODULE_REPO but it did not show the not available online error, and it showed available online for the modules completely not installed.
But it also showed no updates.

[jbusch@pbx ~]$ sudo fwconsole ma upgradeall
[sudo] password for jbusch: 
Cannot load the ionCube PHP Loader - extension already loaded
No repos specified, using: [standard,commercial] from last GUI settings

Up to date.
Updating Hooks...Done
[jbusch@pbx ~]$ sudo fwconsole ma listonline
Cannot load the ionCube PHP Loader - extension already loaded
No repos specified, using: [standard,commercial] from last GUI settings

+----------------------+------------+----------------------------------------------+-------------+
| Module               | Version    | Status                                       | License     |
+----------------------+------------+----------------------------------------------+-------------+
| accountcodepreserve  | 13.0.2.2   | Enabled and up to date                       | GPLv2       |
| adv_recovery         |            | Not Installed (Available online: 15.0.17)    | Commercial  |
| amd                  | 15.0.3     | Enabled and up to date                       | GPLv3+      |
| announcement         | 15.0.3.13  | Enabled and up to date                       | GPLv3+      |
| api                  | 15.0.3.11  | Enabled and up to date                       | AGPLv3+     |
| areminder            |            | Not Installed (Available online: 15.0.14.24) | Commercial  |
| arimanager           | 15.0.3.11  | Enabled and up to date                       | GPLv3+      |
| asterisk-cli         | 14.0.3     | Enabled and up to date                       | GPLv3+      |
| asteriskinfo         | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| backup               | 15.0.10.46 | Enabled and up to date                       | GPLv3+      |
| blacklist            | 15.0.2.12  | Enabled and up to date                       | GPLv3+      |
| broadcast            |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| builtin              |            | Enabled; Not available online                |             |
| bulkhandler          | 13.0.23    | Enabled and up to date                       | GPLv3+      |
| calendar             | 15.0.4.21  | Enabled and up to date                       | GPLv3+      |
| callaccounting       |            | Not Installed (Available online: 15.0.24)    | Commercial+ |
| callback             | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| callerid             |            | Not Installed (Available online: 15.0.16)    | Commercial  |
| callforward          | 15.0.13    | Enabled and up to date                       | AGPLv3+     |
| calllimit            |            | Not Installed (Available online: 15.0.5.6)   | Commercial  |
| callrecording        | 15.0.7.14  | Enabled and up to date                       | AGPLv3+     |
| callwaiting          | 15.0.4.4   | Enabled and up to date                       | GPLv3+      |
| cdr                  | 15.0.17.6  | Enabled and up to date                       | GPLv3+      |
| cel                  | 15.0.15.11 | Enabled and up to date                       | GPLv3+      |
| certman              | 15.0.39    | Enabled and up to date                       | AGPLv3+     |
| cidlookup            | 15.0.20    | Enabled and up to date                       | GPLv3+      |
| conferences          | 15.0.7.8   | Enabled and up to date                       | GPLv3+      |
| conferencespro       |            | Not Installed (Available online: 15.0.3.16)  | Commercial  |
| configedit           | 13.0.7.3   | Enabled and up to date                       | AGPLv3+     |
| contactmanager       | 15.0.8.31  | Enabled and up to date                       | GPLv3+      |
| core                 | 15.0.12.44 | Enabled and up to date                       | GPLv3+      |
| cos                  |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| customappsreg        | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| cxpanel              |            | Not Installed (Available online: 15.0.4)     | GPLv3       |
| dahdiconfig          | 15.0.5.7   | Enabled and up to date                       | GPLv3+      |
| dashboard            | 15.0.8     | Enabled and up to date                       | AGPLv3+     |
| daynight             | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| dictate              | 15.0.7     | Enabled and up to date                       | GPLv3+      |
| digium_phones        |            | Not Installed (Available online: 15.0.3)     | GPLv2       |
| digiumaddoninstaller |            | Not Installed (Available online: 13.0.1.1)   | GPLv2       |
| directory            | 15.0.18    | Enabled and up to date                       | GPLv3+      |
| donotdisturb         | 15.0.8     | Enabled and up to date                       | GPLv3+      |
| endpoint             | 15.0.39.33 | Enabled and up to date                       | Commercial  |
| extensionroutes      |            | Not Installed (Available online: 15.0.8)     | Commercial  |
| fax                  | 15.0.21    | Enabled and up to date                       | GPLv3+      |
| faxpro               |            | Not Installed (Available online: 15.0.8.12)  | Commercial  |
| featurecodeadmin     | 13.0.6.11  | Enabled and up to date                       | GPLv3+      |
| filestore            | 15.0.3.12  | Enabled and up to date                       | AGPLv3      |
| findmefollow         | 15.0.24    | Enabled and up to date                       | GPLv3+      |
| firewall             | 15.0.8.4   | Enabled and up to date                       | AGPLv3+     |
| framework            | 15.0.17.17 | Enabled and up to date                       | GPLv2+      |
| fw_langpacks         | 14.0.1     | Enabled and up to date                       | GPLv3+      |
| hotelwakeup          |            | Not Installed (Available online: 15.0.5.5)   | GPLv2       |
| iaxsettings          | 15.0.8     | Enabled and up to date                       | AGPLv3      |
| infoservices         | 15.0.3     | Enabled and up to date                       | GPLv2+      |
| iotserver            |            | Not Installed (Available online: 15.0.2.6)   | Commercial  |
| ivr                  | 15.0.29    | Enabled and up to date                       | GPLv3+      |
| languages            | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| logfiles             | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| manager              | 15.0.10    | Enabled and up to date                       | GPLv2+      |
| miscapps             | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| miscdests            | 15.0.2.12  | Enabled and up to date                       | GPLv3+      |
| music                | 15.0.22    | Enabled and up to date                       | GPLv3+      |
| oracle_connector     |            | Not Installed (Available online: 15.0.2)     | Commercial  |
| outroutemsg          | 15.0.9     | Enabled and up to date                       | GPLv3+      |
| paging               | 15.0.4.29  | Enabled and up to date                       | GPLv3+      |
| pagingpro            |            | Not Installed (Available online: 15.0.1.21)  | Commercial  |
| parking              | 15.0.15.4  | Enabled and up to date                       | GPLv3+      |
| parkpro              |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| pbdirectory          | 2.11.0.6   | Enabled and up to date                       | GPLv3+      |
| phonebook            | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| phpinfo              | 13.0.2     | Enabled and up to date                       | GPLv2+      |
| pinsets              | 15.0.1.15  | Enabled and up to date                       | GPLv3+      |
| pinsetspro           |            | Not Installed (Available online: 15.0.4)     | Commercial  |
| pm2                  | 15.0.4     | Enabled and up to date                       | AGPLv3+     |
| pms                  |            | Not Installed (Available online: 15.0.2.48)  | Commercial  |
| presencestate        | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| printextensions      | 13.0.3.4   | Enabled and up to date                       | GPLv3+      |
| queueprio            | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| queues               | 15.0.27    | Enabled and up to date                       | GPLv2+      |
| queuestats           |            | Not Installed (Available online: 15.0.3.31)  | Commercial  |
| qxact_reports        |            | Not Installed (Available online: 15.0.3.28)  | Commercial  |
| recording_report     |            | Not Installed (Available online: 15.0.4.33)  | Commercial  |
| recordings           | 15.0.3.15  | Enabled and up to date                       | GPLv3+      |
| restapi              | 13.0.21.2  | Enabled; Not available online                | AGPLv3      |
| restapps             | 15.0.19.17 | Enabled and up to date                       | Commercial  |
| ringgroups           | 15.0.11.11 | Enabled and up to date                       | GPLv3+      |
| sangomaconnect       | 15.0.14    | Enabled and up to date                       | Commercial  |
| sangomacrm           |            | Not Installed (Available online: 15.0.21)    | Commercial  |
| setcid               | 15.0.9     | Enabled and up to date                       | GPLv3+      |
| sipsettings          | 15.0.6.31  | Enabled and up to date                       | AGPLv3+     |
| sipstation           |            | Not Installed (Available online: 15.0.5.16)  | Commercial  |
| sms                  | 15.0.15    | Enabled and up to date                       | Commercial  |
| soundlang            | 15.0.5.10  | Enabled and up to date                       | GPLv3+      |
| speeddial            | 2.11.0.4   | Enabled and up to date                       | GPLv3+      |
| superfecta           | 15.0.2.28  | Enabled and up to date                       | GPLv2+      |
| sysadmin             | 15.0.21.17 | Enabled and up to date                       | Commercial  |
| timeconditions       | 15.0.15.9  | Enabled and up to date                       | GPLv3+      |
| tts                  | 15.0.11    | Enabled and up to date                       | GPLv3+      |
| ttsengines           | 15.0.4.7   | Enabled and up to date                       | AGPLv3      |
| ucp                  | 15.0.6.26  | Enabled and up to date                       | AGPLv3+     |
| userman              | 15.0.35    | Enabled and up to date                       | AGPLv3+     |
| vega                 |            | Not Installed (Available online: 15.0.10)    | Commercial+ |
| vmblast              | 15.0.11.6  | Enabled and up to date                       | GPLv3+      |
| vmnotify             |            | Not Installed (Available online: 15.0.12)    | Commercial  |
| voicemail            | 15.0.18.21 | Enabled and up to date                       | GPLv3+      |
| voicemail_report     |            | Not Installed (Available online: 15.0.6)     | Commercial  |
| vqplus               |            | Not Installed (Available online: 15.0.7.21)  | Commercial  |
| weakpasswords        | 13.0.2     | Enabled and up to date                       | GPLv3+      |
| webcallback          |            | Not Installed (Available online: 15.0.6.3)   | Commercial  |
| webrtc               |            | Not Installed (Available online: 15.0.10)    | GPLv3+      |
| xmpp                 |            | Not Installed (Available online: 15.0.6.7)   | AGPLv3      |
| zulu                 |            | Not Installed (Available online: 15.0.58.9)  | Commercial  |
+----------------------+------------+----------------------------------------------+-------------+
[jbusch@pbx ~]$

So I reset it, now I have updates.


(Jared Busch) #11

While resetting the repo manually is a work around, this is a huge problem and will lead to systems not getting updated because admins are not getting notices.

Edit: Is there way to see hidden/read only settings with fwconsole? I had to resort to the database.

I could not find it in advanced settings even with ignoring the warnings in the GUI about readonly settings in order to determine what that was set to.
image
(no, not really scary to me, but you get the point)


#12

Yeah, when I went to do the upgrade, I got this message, “You are not using the standard FreePBX repository servers. By not using these servers you will miss out on important security notifications, beta releases and add-ons.”


(Jared Busch) #13

GUI? Because I never do updates in the GUI.


#14


(Jared Busch) #15

Oh for the upgrade to 15. Sorry missed/forgot about that part.

Likely just a check no one thought to update for the new repo info.


#16

Well, version 14 also had updates to modules it needed before it could get this far, Previously, it just reported could not connect to repos to get the upgrades


(Matthew Fredrickson) #17

That is good data. So if I’m reading correctly, it might be localized to the legacy mirror server (mirror1), and when you swapped to the more modern mirror infrastructure (mirror.freepbx.org) it resolved itself?

Sounds like like maybe mirror1 might be having some problems. @qwell - does that ring any bells as far as any recent updates we might have made?


(TheJames) #18

Mirror 1 should be put to pasture :upside_down_face:


#19

I saw a notification on another PBX of one update available.

When I try to do the update,

Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org). Online modules are not available.


(Jason Parker) #20

The Distribution being RasPBX is very interesting to me. Can you verify what your /etc/sangoma/pbx-brand has in it?