Mircom TX3 Nano Extension Wont Register to FreePBX


(Defcomllc) #1

I have a FreePBX deployment onsite at a client. Latest version and all updates

It currently has a D65 and a CISCO SPA112 running on it and SipStation trunk. Runs great no issues.

Im installing 2 new residents touch screen call boxes for the front lobby and rear door to the high rise that support SIP.

I’ve cannot get the 1st one Im setting up to register. Asterisk log file just shows Endpoint will exceed max contacts of 1 each time it tries to register. Its setup as a PJSIP extension… The SIP documentation for this Mircom TX3 Nano regarding Sip doesnt give much details other than to use Onsip or their SIP service for support but states you can use your own on premise or cloud SIP server…

Here is the SIP settings in the device… I tried the Username and Auth Username both as just the extension (201) or extension at IP and port… Still wont register. Password is copied straight from FreePBX extension password.

And this is what I see in the log

Any suggestions?


(Defcomllc) #2

Running SNGREP I see it keep trying to register on port 5060 even though I added my UDP port after the sip server address. Could it be this is the reason and Mircom has 5060 hard programmed into this call box?


(Andrew) #3

Is there anything accidentally registered on that extension already?

asterisk -x "pjsip show contacts 201"

Alternatively, what port are you listening on for PJSIP? I don’t see anything about port customization in their documentation - LT-995_TX3_Touch_Screen_Configuration_and_Administration_Manual.book (mircom.com) on page 167 - so I don’t know if it’s supported to specify a port number.


#4

I know nothing about the Mircom, but suggest that you try setting Domain to
192.168.50.2:55061
and Max Contacts to 4.

Also, please explain why the phone and PBX appear to be on different subnets. Are these simply routed together, or is there NAT, VPN or other complexity involved?


(Defcomllc) #5

Nope nothing registered on Ext 201… I just ran asterisk -x “pjsip show contacts 201” and it only shows Ext 100, 101, 102 and my 2 sip trunks registered.

I use a non standard port for PJSIP 55061…


(Defcomllc) #6

That is exactly what I did, set domain to 192.168.50.2:55061… I tried max contacts 2 but I will try 4.

Because 192.168.1.0 subnet is the main mgmt LAN that the call boxes are installed on so the General Manager can access them on the main LAN to update resident names as the move in and out… The FreePBX deployment and other phones are on a FreePBX VLAN I setup but they are routed together and the subnet in question is added in FreePBX firewall as trusted and I can access the FreePBX webgui and SSH at 192.168.50.2 from the mgmt lan 192.168.1.0/24… I can try assigning the Mircom boxes a static on the FreePBX VLAN but that shouldnt make a difference, they are routed together…


(Andrew) #7

If you’ve done that and it still is trying to register on 5060 then it appears that isn’t accomplishing what we want. Is there another setting exposed for port number? You may need to contact the manufacturer.


(Defcomllc) #8

Also, this first box Im setting up is the TX3 Nano… The bigger box at the front door is the TX3 Touch 22" that I havent started configuring yet.

So Im using https://mircom.com/wp-content/uploads/pdf/LT-1194_TX3-Nano_Configuration_Manual.pdf

Section 3.11.

Like you said, I dont see anything regarding port number… I am a Mircom partner and have certifications on these devices but when it comes to SIP they make it pretty well known your own your own if you dont use their SIP service but they say it supports 3rd part and even mentions Asterisk in the documentation.

Not sure if I have to change my PJSIP port to 5060 to work with this device?


(Andrew) #9

Might be worth a shot at least, to narrow down if that’s the issue.


(Defcomllc) #10

Thats what Im thinking…


#11

In your post edited at 16:28 PDT you show errors in the Asterisk log “Registration attempt … will exceed”. Assuming that you are certain that pjsip “port to listen on” was set to 55061 (and Asterisk restarted) at the time, it seems virtually certain that the device REGISTER requests had a destination port of 55061.

However, that conflicts with the Call Flow you posted. Are you sure that no configuration changes were made to the device or the PBX between those two captures?


(Defcomllc) #12

100% positive PJSIP port is 55061… Has been since day 1 and is right there in Asterisk SIP Settings under PJSIP tab UDP port 55061…

Ive been making lots of changes as stated above trying to get it to register… But I have only seen 192.168.1.141:5060 in SNGREP for Ext201…

Going back and looking at Asterisk Log files it never said 55061 in there… always IP of the Mircom (192.168.1.141:5060)

[2021-10-06 18:49:12] WARNING[3494] res_pjsip_registrar.c: Registration attempt from endpoint ‘201’ (192.168.1.141:5060) to AOR ‘201’ will exceed max contacts of 1


#13

That is just saying that the source port of the request from 192.168.1.141 was 5060, which is what would be expected and is not in any way a problem.

Are you still seeing this message, even with Max Contacts set to 4?


(Defcomllc) #14

hmmm…no, now says unsupported transport???


(Defcomllc) #15

I had switched it to TCP in the Mircom Nano since TCP uses 5060 on my FreePBX but Im getting that unsupported transport even though I enabled TCP in Asterisk SIP sittings port 5060 and restarted asterisk… I just put it back to UDP and restarting the NANO… let me see what that says in the log now…


(Defcomllc) #16

So i rebooted the Mircom and it came back online and says Registered and the Asterisk log says it registered as well as SNGREP then shows unsupported transport???


(Defcomllc) #17

Weird part is Asterisk log says transport is TCP not UDP even though I changed it from TCP to UDP in the Mircom then rebooted and i just checked, it still says registered and transport UDP is selected so IDK…


(Defcomllc) #18

Well I disabled TCP transport in Asterisk SIP settings, only UDP enabled on 55061… UDP is selected in the Mircom NANO… I rebooted the Nano 3x and every time it registers and stays registered… So I guess Ill have to try making a test call when Im back onsite…

The only concerning thing is the Asterisk log keeps showing unsupported transport for 201 after it registers and says reachable… so idk