Minimal installation on uClinux - < 250 megs space

Is is possible to install a stripped down version of freepbx & dependencies? aware the dependencies are responsible for taking up a lot of the space. Have tried asterisk gui and voiptel gui, but there ain’t anything like freepbx!

This is for an ip01 computer with uClinux installed. Has one zap channel built in


We did this on the PIKA Warp appliance and it works reasonably well. I believe they have an ISO for their appliance with FreePBX. It’s a major undertaking to get things to work. There is a lot built into FreePBX now to streamline performance but there is a lot to do on the appliance ISO and PHP side to achieve a workable system.

When we originally did the port (which was Schmooze Communications / ethans who did the bulk of it on the appliance side) we had 7-14 second page load times. Once we tuned some things in FreePBX and did some significant tuning and tricks in the PHP installation of the appliance, we got that down to typically 0.3-0.7 sec page load times for most page loads.

So - either be prepared to do a lot of work or consider having a look at the PIKA Warp appliance if you really need such a solution. They have two slots and a variety of cards you can plugin for different types of telco connectivity.

thanks Philippe!
will see if the ip01 users think !

Please let me use this opportunity to inform you that the VoIPtel GUI was replaced by VoIPtel CE and SE last December 2008. For more info please visit

As commented by Mr. Lindheimer it is a large undertaking to port FreePBX to the Blackfin platform. I know that such a project was started last year, but apparently it is still not finished.

By the way, the IP01 with it’s 256MB FLASH, 64MB RAM and 400Mhz Blackfin DSP could hardly be labeled a computer and would not be able to run a 250MB firmware. In comarison the VoIPtel CE firmware is around 5MB before it is decompressed and loaded into RAM.

Best regards

Jan Bjorkhaug

the pika people are referring me to a user site:
this references a tarball at:

unpacking this leads to a collection of jfss2 image files which I do not understand

is there anyway I can obtain an ‘ordinary’ freepbx tarball for compilation, with the modified files that were used for this project?