Migration to new install

Hi

I am currently running an old small installation on a Raspberry Pi - on Asterisk 11.18.0 (FreePBX 2.11.0.43).

I want to migrate to a new, fresh install - based on FreePBX 13.0.191.10 (Asterisk 13.15.0) - as the underlying Raspbian OS also has jumped versions since my initial install.

What would be the easiest way to migrate (or convert) the existing config - together with any defined entries in e.g. extensions_custom.conf and any extensions, system recordings and so on?

Will it be to do a backup in the old FreePBX GUI - and restore the backup on the new server ?

Regards
Brian

Your safest route will probably be to create a CSV file of your extensions and import it using the bulk handler (or whatever it’s called now). The backup and restore route will almost assuredly fail in a spectacular and “waste of a couple of good days” way.

If you don’t have a lot of extensions or trunks, it might be easiest to just set the system up from scratch.

Use our conversion tool. https://wiki.freepbx.org/display/PPS/Elastix+and+PBXinaFlash+to+FreePBX+Distro+Conversion+Tool

1 Like

I have just tried a manual migration - the setup is quite simple…

I have a config to handle calls with no caller-id, but something fails on the new server…

From the Asterisk log I have:

[2017-04-28 19:32:21] VERBOSE[2740][C-00000004] netsock2.c: Using SIP RTP TOS bits 184
[2017-04-28 19:32:21] VERBOSE[2740][C-00000004] netsock2.c: Using SIP RTP CoS mark 5
[2017-04-28 19:32:21] VERBOSE[5116][C-00000004] pbx.c: Executing [[email protected]:1] Zapateller("SIP/82132307-00000005", "answer,nocallerid") in new stack
[2017-04-28 19:32:21] VERBOSE[5116][C-00000004] pbx.c: Executing [[email protected]:2] Wait("SIP/82132307-00000005", "3") in new stack
[2017-04-28 19:32:24] WARNING[5116][C-00000004] pbx.c: No application 'SetMusicOnHold' for extension (from-external-custom, s, 3)
[2017-04-28 19:32:24] VERBOSE[5116][C-00000004] pbx.c: Spawn extension (from-external-custom, s, 3) exited non-zero on 'SIP/82132307-00000005'

The MusicOnHold module is loaded - so I am wondering what I have forgot, since indbound calls are dropped after approx. 5 seconds on the new setup…

The SIP trunk has the following config (sip_additional.conf):

[82132307]
username=82132307
type=friend
secret=xxxxxxxxxxxxxx
nat=force_rport,comedia
insecure=port,invite
host=xx.yy.zz
dtmfmode=rfc2833
context=from-external-custom
canreinvite=no

/Brian

Requires ZendGuardLoader for linux - for ARM CPU (I run a small install on a Raspberry Pi).

So this does not look like a way to solve it…

Hello Tony,

I’m trying to migrate a Freepbx 12 to a new Freepbx Distro. I used the conversion tool and it seems that the process ends without errors. But when I access to Freepbx GUI, the performance is far far worst than the previous installation. Asterisk process reaches 100% when I try to edit an extension, for example.
I’m tried this process between two virtual machines several times with the same problem.
Do you know why it results in this low performance? Or where can I find some hints to try to solve it?

Regards,

This topic was automatically closed after 5 days. New replies are no longer allowed.