Migrate from centos freepbx 15 to asterisk 16 on debian 11

Hello
I followed How to Install FreePBX 16 on Debian 11 with Asterisk 16 - FreePBX Documentation - Documentation and have a working system.

[ thank you Bill Simon! ]

Next I want to restore a backup from our production system which has these versions:
Asterisk Version: 13.38.3
FreePBX 15.0.17.64

the new system versions:
Asterisk Version: 16.16.1
FreePBX 16.0.10.43

Question: to start should we upgrade the production system to freePBX version 16 ?

PS: I’ll make a snapshot in case a retry is needed.

Hey, you’re welcome. I’d try backup from 15 and restore to 16 without upgrading the source system first.

Hello Bill
I recently upgraded to 15 on our production system - and the backups are very different . an improvement no doubt , yet I am just getting familiar with the new backup system.

So I will restore all the modules and recordings from he backup unless you advise something else.

after the restore , I did a quick check of the system.

connectivity , extensions look good.

Dashboard had these
tampered file warning: this was a few seconds old:

Module: “FreePBX Framework”, File: “/var/lib/asterisk/agi-bin/phpagi-asmanager.php missing”
Module: “FreePBX Framework”, File: “/var/lib/asterisk/agi-bin/phpagi.php missing”

this was 40 min old so before restore i assume:
Retrieve conf failed to copy file(s) from a module’s agi-bin dir: copy(/var/lib/asterisk/agi-bin/calendar.agi): failed to open stream: No such file or directory
copy(/var/lib/asterisk/agi-bin/contactmanager.agi): failed to open stream: No such file or directory

Modules:
just one is highlight reddish: FreePBX Framework
I assume that may be related to the tampering warning.

I’ll work on issues and post back.

Also during restore these were noticed:

hundreds of these lines, I assume no issue:
Importing AstDB family AMPUSER from core
Importing AstDB family AMPUSER from core
Importing AstDB family AMPUSER from core

ucp had errors as expected

Error Output:
================
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
 on line 235 of file /var/www/html/admin/libraries/Composer/vendor/symfony/process/Process.php
#0 /var/www/html/admin/modules/sms/Restore.php(75): Symfony\Component\Process\Process->mustRun()
#1 /var/www/html/adminh/modules/sms/Restore.php(36): FreePBX\modules\Sms\Restore->processSms()
#2 /var/www/html/admin/modules/backup/Handlers/Restore/Common.php(138): FreePBX\modules\Sms\Restore->runRestore()
#3 /var/www/html/admin/modules/backup/Handlers/Restore/Common.php(126): FreePBX\modules\Backup\Handlers\Restore\Common->runRestore()
#4 /var/www/html/admin/modules/backup/Handlers/Restore/Multiple.php(61): FreePBX\modules\Backup\Handlers\Restore\Common->processModule()
#5 /var/www/html/admin/modules/backup/Console/Backup.class.php(324): FreePBX\modules\Backup\Handlers\Restore\Multiple->process()
#6 /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php(255): FreePBX\Console\Command\Backup->execute()
#7 /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php(992): Symfony\Component\Console\Command\Command->run()
#8 /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php(255): Symfony\Component\Console\Application->doRunCommand()
#9 /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php(148): Symfony\Component\Console\Application->doRun()
#10 /var/lib/asterisk/bin/fwconsole(163): Symfony\Component\Console\Application->run()
#11 {main}
Processing superfecta
The module superfecta does not seem to support restores.



xmpp and firewall errors as expected

 
Error Output:
================
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
 on line 235 of file /var/www/html/admin/libraries/Composer/vendor/symfony/process/Process.php
        Error installing xmpp reason(s): Failed to run installation scripts on line 29 of file /var/www/html/admin/modules/backup/Handlers/FreePBXModule.php
There were warnings during the restore process
        Can't find the module data for callback
        Can't find the module data for callerid
        Can't find the module data for calllimit
        Can't find the module data for conferencespro
        Can't find the module data for miscdests
        Can't find the module data for setcid

note we have not use superfecta in some years.

I tried reinstall the module, did not fix.

Forced downgrades and re-installs:

FreePBX Framework 16.0.10.43 will be re-installed to online version 16.0.10.43

after reinstall:

  • module still highlighted red
  • warning still at dashboard

cli:

ls  /var/lib/asterisk/agi-bin 
ls: cannot access '/var/lib/asterisk/agi-bin': No such file or directory

looks like a symlink is needed:

[email protected]:[~]:# updatedb
[email protected]:[~]:# locate asterisk/agi-bin 
/usr/share/asterisk/agi-bin
/usr/share/asterisk/agi-bin/attendedtransfer-rec-restart.php
/usr/share/asterisk/agi-bin/calendar.agi
/usr/share/asterisk/agi-bin/checksound.agi
/usr/share/asterisk/agi-bin/contactmanager.agi
/usr/share/asterisk/agi-bin/dialparties.agi
/usr/share/asterisk/agi-bin/directory
/usr/share/asterisk/agi-bin/directory.agi
/usr/share/asterisk/agi-bin/directory.lib.php
/usr/share/asterisk/agi-bin/enumlookup.agi
/usr/share/asterisk/agi-bin/fixlocalprefix
/usr/share/asterisk/agi-bin/list-item-remove.php
/usr/share/asterisk/agi-bin/outboundRouteEmail.php
/usr/share/asterisk/agi-bin/page.agi
/usr/share/asterisk/agi-bin/paging_call_spooler.agi
/usr/share/asterisk/agi-bin/parkfetch.agi
/usr/share/asterisk/agi-bin/parkuser.php
/usr/share/asterisk/agi-bin/phpagi-asmanager.php
/usr/share/asterisk/agi-bin/phpagi.php
/usr/share/asterisk/agi-bin/queue_devstate.agi
/usr/share/asterisk/agi-bin/recordings.agi
/usr/share/asterisk/agi-bin/user_login_out.agi
/usr/share/asterisk/agi-bin/wakeconfirm.php
/usr/share/asterisk/agi-bin/wakeglobal.php
/usr/share/asterisk/agi-bin/wakeup

ln -s /usr/share/asterisk/agi-bin /var/lib/asterisk/agi-bin

Did not fix.

I’ll try restarting asterisk …

did not fix.

rebooting - which naturally should not need to be done.

tried this. did not fix

[email protected]:[~]:# ls -l  /var/lib/asterisk/agi-bin/phpagi-asmanager.php

-rwxrwxr-x 1 asterisk asterisk 40792 Dec 30 09:55 /var/lib/asterisk/agi-bin/phpagi-asmanager.php*
[email protected]:[~]:# 
[email protected]:[~]:# ls -ld  /var/lib/asterisk/agi-bin
lrwxrwxrwx 1 asterisk asterisk 27 Dec 30 14:48 /var/lib/asterisk/agi-bin -> /usr/share/asterisk/agi-bin/
[email protected]:[~]:# rm /var/lib/asterisk/agi-bin
/bin/rm: remove symbolic link '/var/lib/asterisk/agi-bin'? y
[email protected]:[~]:# rsync -aH /usr/share/asterisk/agi-bin/  /var/lib/asterisk/agi-bin/
[email protected]:[~]:# systemctl restart freepbx

so unless i hear other advise I’ll upgrade the production system to FBX 16 .

restore snapshot of debian bullseye freepbx

and try again.

after restoring the system snapshot from before the restore, the dashboard shows no issues.

next : upgrade production system to 16 , make a backup and restore to debian 11.

after upgrading the production pbx to -16 , backup then restore, same issue:

Module: "FreePBX Framework", File: "/var/lib/asterisk/agi-bin/phpagi-asmanager.php missing"
Module: "FreePBX Framework", File: "/var/lib/asterisk/agi-bin/phpagi.php missing" 

Next will make a backup which excludes Framework …

after restoring a backup which excluded framework,

dashboard showed no issues.

next [ sometime when office is closed ] will try using the debian 11 system as the production phone system .

PS: I think that the upgrade to 16 was not necessary. so excluding framework on a v15 backup then restore may work.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.