Making FreePBX work with Gempro GSM Gateway

My PBX Setup consists of following components

  1. FreePBX
  2. Gempro GSM Gateway for dialing out GSM

Following extensions are setup

  1. 900 - My extesnion
  2. 0 - Gempro gateway

Gempro has a feature called “1 Stage ( Called Num.)” by which whenever the calls land with the dial digits, the gateway just initiates an outgoing call with the same number.

For this I have created an

  1. An Custom Trunk with dial command "local/[email protected]
  2. An outgoing route with a dial pattern any number starting with 0 to be routed to the custom trunk

The calls are successfully getting routed to the 0 extension of gempro gateway but when we enable the “1 Stage ( Called Num.)” , gempro just dials out the number in GSM as “0” as that is the dialled digit it is getting from trunk.

Could anyone please help out on how to fix it.