MAJOR Backup and Restore BUG

I have system #1 on freepbx version
asterisk version 18.17.1 (I have also tried version 20)
I have set up a new server (system #2) with the exact same freephbx and asterisk versions.
both systems where fully up to date and running backup and restore version 16.0.67
I even tried downgrading to a different version version 16.0.63 and bellow just gave an error when trying to make a backup
16.0.64 and above had the following issues

I created a full backup on “system #1” and I have restored it on “system #2

my extensions, inbound and outbound routes, trunks, did not restore on the new pbx.

how do we get this issues resolved?

I get this error after restore is complete. Correct me if I am wrong but the Core module includes the routes, trunks and extensions correct?

Invalid argument supplied for foreach() on line 13 of file /var/www/html/admin/modules/core/Restore/Devices.phpEdit Description

My suggestion would be to file a bug report containing the backup.log file from both the backup and restore machines.

I did create a but report and a support ticket. I have not gotten a reply on the bug report and on the support ticket they want me to purchase support credits

Replicated issue. IVRs not restored for me on same scenario

we got this resolved by updating the “core” module

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.