Low Memory Limit problem


i am a newbie in FreePBX and Asterisk and i am facing problems after installing and configuring both…

when i open the FreePBX admin interface, a warning message appears

Your memory_limit, -1M, is set too low and may cause problems. FreePBX is not able to change this on your system. You should increase this to 100M in you php.ini config file

and i changed my memory_limit in php.ini to 100M and also to 128M but this message still there.
I searched for this error but the solution was to change memory limit …

so anyone please help

i installed asterisk and freepbx on Ubuntu 10.10

Thanks in advance
Rana Ramez

I found memory_limit=-1 in php.ini file located in /etc/php5/cli and i changed it to 128M

but now i want to reload or refresh this notice about memory limit to see if that worked but i can’t

i have tried amportal restart and asterisk -r then reload and restarting apache and also applying configuration orange button but all didn’t work

so how can i refresh this error to know if it works or not

Thanks a lot for replying

Debes cambiar tambien este valor en el archivo etc/php.d/elastix.ini

Somewhere your memory limit is being forced down and as the error points out, FreePBX’s attempt to increase it is failing.

Make sure it is not set somewhere else that is overriding your php.ini settings, maybe somewhere in php.d/* or in an apache related setting that is configuring mod_php.

any help would be appreciated