Loud and distorted audio on Sangoma S500


(John) #1

I’m working with a company to replace all their desk phones and we are trying out some S500’s but the volume on the handset is really loud and even distorted. This occurs on the DTMF feedback, dialing and remote audio. Even with the volume adjust set all the way down to the 1, the lowest it will go, the volume is still too loud to be comfortable. The web GUI has a volume amplification section and a handset send volume but even with that set to -6, the issue persist.

Model S500
Firmware
Boot 2.0.3.36
IMG 2.0.4.74
ROM 2.0.4.74
DSP 9.0.3

Attached to PBX Firmware:
12.7.6-1910-1.sng7

PBX Service Pack:
1.0.0.0


(Mike Waldron) #2

We had this issue with this phone and we narrowed it to G722. Try changing your FreePBX SIP codec order with G711 at top. This fixed it for two installations with S500s having the same issue with “sending” audio being shouty and distorted. Have since moved to Yealinks and never looked back.

See:


(Brian Nakash) #3

It’s the firmware. Revert your phones to the 1.58 firmware package in endpoint manager. This should correlate to the .72 IMG.


(Security Guy) #4

Thank you Brian – I’ve been plagued by audio problems, especially on the headset connected to my Sangoma S700. Reverting to 2.0.4.72 solved the problem. (.73 and .74 both cause nasty distortion).


#5

Client with S705s was having the over-loud handset receive volume issue. Rolling back to 1.58 resolved it for them. Not sure what’s going on with 1.59 and 1.60, but something is certainly amiss.


(Mike Waldron) #6

Just tried upgrading a client and had the same issue. Moved back to 1.58 / 2.0.4.72 fixed it.