Lost with fax setup -- still no luck [SOLVED]

hi all,

i am running the latest version of FreePBX 2.10.x on Asterisk 1.8.20-1.

i have successfully setup Digium’s FFA (Free Fax for Asterisk) and I am able to see fax information on the command line in asterisk by issuing:

fax show stats

i am now proceeding to the FreePBX interface to implement an inbound route for incoming faxes. when i goto “connectivity” then “inbound routes”, i can see “fax detection” and if i turn that on i have a choice of DAHDI or SIP. in either case, i cannot select any destination that could deal with a fax except an extension.

when i goto “applications” -> “extensions” and look at each extension type, there is no mention of the word “fax” and the only mail addresses are associated with dictation and voice mail.

i have the schmooze fax configuration module installed, however, i just don’t seem to have the same interface options as others who have posted to this list.

many thanks


These settings are in the virtual extension type.

hi skyking,

that’s just it – nothing on virtual. the word “fax” cannot be found on the page.

hi again skyking – here’s what modules i have:

you’re a star :slight_smile:


/var/lib/asterisk/bin/module_admin list
no repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Module Version Status

announcement Enabled
asterisk-cli Enabled
asteriskinfo Enabled
asternic_cdr 1.5 Enabled
backup Enabled
blacklist Enabled
builtin Enabled
bulkdids Enabled
bulkextensions Enabled
callback Enabled
callforward Enabled
callrecording Enabled
callwaiting Enabled
campon Enabled
cdr Enabled
cidlookup Enabled
conferences Enabled
core Enabled
customappsreg Enabled
customcontexts Enabled
dashboard Enabled
daynight Enabled
dictate Enabled
directory Enabled
disa Enabled
donotdisturb Enabled
endpointman Not Installed (Locally available)
fax Enabled
featurecodeadmin Enabled
findmefollow Enabled
fop2admin 1.2.11 Enabled
framework Enabled
fw_ari Enabled
fw_langpacks Enabled
iaxsettings Enabled
infoservices Enabled
irc Not Installed (Locally available)
ivr Enabled
javassh Enabled
languages Enabled
logfiles Enabled
manager Enabled
miscapps Enabled
miscdests Enabled
music Enabled
outroutemsg Enabled
paging Enabled
parking Enabled
pbdirectory Enabled
phonebook Enabled
phpinfo Enabled
pinsets Enabled
printextensions Enabled
queueprio Enabled
queues Enabled
recordings Enabled
restart Enabled
ringgroups Enabled
setcid Enabled
sipsettings Enabled
sipstation Not Installed (Locally available)
timeconditions Enabled
userpaneltab Enabled
vmblast Enabled
voicemail Enabled
weakpasswords Enabled

In extensions use the drop down to select virtual… then listen to SkyKing

hi atarzi,

i guess that i have not been clear enough – so let me restate:
in any “extension type” [sip/iax/dahdi/custom/virtual] the word fax does not appear anywhere on the page/extension, nor in any drop down on any extension or page.

i’m now thinking that the module install process is busted on a manual install of freepbx given the absence of the word fax. the ONLY “fax” options are:

“connectivity” -> “inbound routes”
“settings” -> “fax settings”
“admin” -> “feature codes” -> “Dial System Fax 666 Enabled”

i have three freepbx installs, and they’re all the same.

many thanks!


hi all,

sorry to bother, but i’m simply not getting this and i am getting screamed at :frowning:

so – i downloaded freepbx distro and installed to see if i have the same user interface. it looks as though i do have the same.

neither in freepbx distro, nor in my own manual install, do i see the word “fax” anywhere in on the web page for editing an extension of any type (and in particular, Custom and Virtual).

which mail address field should be filled out? is their a “FAX” dial technology?

i’m just lost.



Why are you getting screamed at? Not sure what you are doing wrong:

Have you considered engaging FreePBX paid support?

hi skyking – ok – going to have to get paid support, but out of simple curiousity – the screen snip showing the words

“Fax Email”

is that coming from your “Applications” -> “Extensions” -> “Virtual Exten” screen?



Yes, that’s exactly where it is. I also just checked a system that was just installed on beta 2.11, no configuration done, I was going to play with the latest beta this weekend. It also has the FAX settings. They are in all extension types because you can do FAX detection on any channel technology as it is done at the RTP level.

I am also interested in what is wrong.

Drum Roll Please:

The fax parameter doesn’t appear until after the first save of the extension.

So – create a virtual extension, save it, re-edit it, and you will find the fax parameter that didn’t appear on the initial setup screen.

going to drink heavily now.



and curiously, in advanced settings, i have

Display Friendly Name? True False
Display Hidden Settings? True False
Display Readonly Settings? True False
Override Readonly Settings? True False

All set to true

That has nothing to do with anything other than how the advanced settings are displayed and modified.

Honestly, I can’t think of anything that would stop the fax fields from displaying. I have not gone and looked at the code.

I am surprised nobody else has chimed in.

morning skyking,

just checked on my freepbx x64 version 1.8 that i downloaded yesterday – same behavior – fax settings appear only after 1st save.



Wow, yes that would be true. Many settings only appear after the save.

I guess it’s something if you don’t work with the system could trip you up.

Sorry this was so difficult.

Hope your liver is OK.