Login Incorrect but only from *98 and outside lines

This is a bit strange, I’m not sure where to start on this one so am asking for a little input.

Here is an example of the problem.

On my own desk phone, a LinkSys SPA941, I can hit *97, am prompted for password and get into vm.
On the same phone, if I type *97, then enter my extension then password, I constantly get ‘login incorrect’.

I recently modified things a little, adding a FQDN in both vm_email.inc and voicemail.conf so that I could get web access to email working. Everything seems to be working fine other than the red light on the phones aren’t coming on anymore when messages come in and now this.

This seems to be happening when using *98 and when calling in from outside. In other words, vm access only seems to be working when you use *97. It’s early yet so I’ll update this once I hear from a few users to confirm this.

I’m not sure where to start looking because I don’t want to break the other work I’ve done.
I’ll be happy to provide what ever information is required.

Mike

There is a user who doesn’t have a SIP phone, he just calls in using a regular phone to pick up messages. He calls in using his cell phone, hits * during the announcement, is prompted for his passcode, enters it and gets into his vm.

I use my SIP phone, which is internal, on the same LAN as the PBX. I dial the full number, not just the extension. I get the recording, I hit *, am prompted for his passcode, I enter it, and the system always tells me ‘login incorrect’.

So, I’m no pro at this… I’m guessing that even though I am dialing the full number, I am still just getting a local connection. Hence, trixbox knows that it is ext 6159 calling another extension, 1762. So, it’s acting as if I was just calling via extension and using *98, am I right?

So, if this is the case, then my problem seems to be, um, NAT related again?

Mike

Mike, The *98 issue is directly related to the change you made placing two different groups of people into different voicemail contexts. *98 assumes the VM context is default, but you now have two groups neither of which are in that context.

Quickest/best solution is to teach people to dial there extension, when they get the vm greeting press * and then enter the password. When you are listening to the vm greeting for that person it knows the vm context and so assumes that is who you want to sign in as.

Otherwise the voicemail code for *98 to get voicemails will need to be customized to support other contexts.

Sounds like assigning a different code for each group is much tougher than your suggestion.

Thanks so much for the help, it is appreciated!

Mike

there are several ways to fix the issue. Like I said simplest is for each person when remote to call there own extension and then ask for voicemail with the * when the intro is played.

Next option is to customize the *98 to support a different context then default. That’s not to hard, in your situation what I’d do is make two copies of it, one for one context and one for the other. Then tell each group the new number to dial.

That or I’m sure the code can be adjusted to search each context until it finds a match. I’ve jsut never had the need to do this as every one of our people have a DID so they know to dial thier own desk number and press * to check voicemail when out of the office.

I went with letting folks know that using their phones, they dial *97 or their ext. Using any other phone, they call their own number, hit * during rec. That’s a nice simple fix.

Now, I have to fix the red light problem. I’m guessing it’s somehow connected to the context option as well. Maybe context needs to have a specific word in there, like default-1 or something. I am using group1, group2.

Mike

I don’t have that issue here with the groups so don’t know what the issue is… Duh, I just looked and see why I’ll bet.

Look at the mailbox field of a extension in question. Change it from [email protected] to [email protected] or [email protected] so that it matches the vmcontext down at the bottom.

Ah, that’s just so cool, red lights are back!

Thank you, again :).

PS: Is there a way of adding someone to multiple groups? This is just out of curiosity, don’t really need it, just wondering if it can be done.

Mike

Not that I know of, but there are other line formats that are/were supported in the voicemail.conf file based on the code written in the directory handler when it parses the file. I’ve never dug into the full voicemail.conf file documentation to see if there is a way to do a alias for a account which if it exists might work.

No big deal, I’ll search that out at some point. Just wondered. Everything seems to be working perfectly now.

Thanks again.

Mike

I did do some digging and even though the FreePBX code has some code in that say’s you can do it, when you do it seems to fail… I’ll have to post a bug/useless code report and see what the reasoning was behind it as I could not find it supported in the asterisk code any more in 1.2 or 1.4… (Maybe a OLD 1.0 thing?)…

It’s not important but it could be useful indeed. It almost makes the standard setup a multi-tenant setup I think is what it’s called.