Logging Verbosety

Let me start by saying this is an Elastix 2.5 HA system. now that Elastix has abandoned Asterisk and its users the forum there is also pretty dead. I have access to the embedded FreePBX backend( I will eventual be moving to FreePBX but its complicated and expencive with the HA option and this is a decent sized system with lots of custom code. It will be a while before we can do a changeover.

what I am running into now is that the logs basically only show “notice” and “warning”. I am getting random reports of things like dropped calls and I need to know what happened (I already know its user error as its always the same people but I need to prove it).

I have always been able to go into logs on an asterisk server and its basically a line for line copy of the CLI. that is what I need and I cant seem to figure it out.

full => debug,error,notice,verbose,warning
console => debug,error,notice,verbose,warning

the free PBX GUI says the same thing. I have seen people say to change verbose to verbose(3) but it gets overwritten every time you reload asterisk.

normally I just watch the CLI if there is a problem but this only happens every couple days and they report it hours or days after it happens so my CLI buffer is long gone as this system gets 600 inbound a day not to mention paging and internal calls.

In /etc/asterisk/asterisk.conf under options

verbose=99 (or less :slight_smile: )

You might want to also add


More in


tried this with verbose=7 and I am still just getting “notice” and “warning”

restarted asterisk and logger.

any other suggestions?

grep console /etc/asterisk/logg*

I think FreePBX has a GUI element to add what you want in console (the CLI) , full (/var/log/asterisk/full) or anything you care to add.

I dont need to do anything with the console it is doing everything perfect with verbosety set at 3. its just that the logs are very slim on info as they are only showing warning and notice and nothign else.

Again which “logs”, you can define as many as you want as often as you want, if the GUI doesn’t work for you add whatever to


yourpersonallog => dtmf,notice,warning,error,debug,verbose,security

should cover most things :wink:

1 Like

There was a bug in the verb. with elx 4. and 2.5.
Edit : /usr/sbin/safe_asterisk
Change these lines:

TTY=9                           # TTY (if you want one) for Asterisk to run on
CONSOLE=yes              # Whether or not you want a console

Next launch service asterisk restart or amportal restart.

After these changes, the logs in /var/log/asterisk/full should reappear.

Jeje, at least they have elimated the bug in Elastix 4 .

1 Like

And 2.5 !

And effectively themselves :wink:

awesome, that did it.

also, strangely enough, Dicko also did it as making a new log actually works as well. I have many clients on 2.5, I can’t believe I never ran into this. some system just run for years with no problems and some are plagued with problems(aka users)

after enditing safe_asterisk in wordpad from winscp I did get an error starting Asterisk
/bin/bash: /usr/sbin/safe_asterisk: /bin/sh^M: bad interpreter: No such file or directory

using dos2unix on the file fixed it.

The firsts version of elx 2.5 , this issue doesn’t exist.
But one day, with an update (i guess in same time when the theme MT has been included), this issue is appeared in elx 2.5.
Same for elx 4.0 and even with a fresh install.
But if you make a fresh install with elx 2.5 without update, there’s no problem.

This way is came from an team member of Elastix.

With notepad ++ you can define the CR (Linux, Windows).=> > \n or \n\r