Local repositry

Dear FreepbxDistro,

Often I have a very slow download speed on the freepbxdistro repositorie’s.
2 days ago a install lasted a total night.
Is it possible for me to mirror your directorie’s to a local host?
I want to edit the kickstart file so it is forwarding to my own web repository.

As I can see I need the following files to copy to my local CentOS web dir:

I am trying to do ‘rsync’ or 'cp -R’
Can you help me a little bit here please?

Would be very happy with your answer!!

I am little further now, quite easy afterall.
wget --mirror http://yum.freepbxdistro.org/centos/5/

This will create a complete copy of the repo including subdirs.

Which mirror?

I am seeing no speed issues. Just did speed test on all 3 yum servers and getting 20-50 Mbps on each one of them

Well, there is obviously something wrong with the freepbxdistro repository server or its bandwidth!
I’m also doing an install right now, and it’s going to take five (5!) hours, maybe more, just to download the packages…
And we’re on a very fast line (50 Mbps) that isn’t used for anything else other than the FreePBX download at the moment!

I hope Tony & co are working on it.

also seen this multiple times, took 3 hours for a full install, an hour and a half just to download packages for the update…

Yes updates can be very large. If you look at the upgrade that upgrades over 300 RPM’s and is a few GB is total size.

Which mirrors are there?

For yum.freepbxdistro.org I get:

Are there other URL based mirrors?

I’m getting a 404 error trying to retrieve:


From the distro and the browser.

Any suggestions would be appreciated.

Our centos yum repos seem to be having a major issue. I did a rsync from Centos earlier today and it removed a ton of packages. I am looking into this now and hopefully will have it fixed but it will take probably most of the night to pull them down and sync them with the servers.

Thanks. Appreciate the quick response!

Was trying to load up a new server, and found I couldn’t get a reliable load from the repos, so I am guessing there is still a big problem?

Tried a couple times with no success, and I had loaded the distro on a different machine with ease last week.

If you all need any more mirrors of your repos, let me know, I’d be more than happy to lend a hand. Used to do that for the TrixBox stuff, which seems to be quite a dead horse at this time…

No their are no problems that I know of. I installed all 4 version yesterday fine and see lots of installs going on throughout today.

OK, I will give it another try, as even trying to get things like the stage2.img was taking forever, yet access to other things on the net seemed to be flying…

Well I came back hours later and then it worked fine, so guess just to much load at the time I was trying.

Going to load up and maintain a bunch of machines here soon, is there any good way to get a copy of the current repos outside of wget? Didn’t seem like there was any FTP or rSync access to the stuff, heck rsync is lovely for such things, and I would even be open to putting the stuff up for access from over here as well for others to help out if there was any interest…

The Distro is acting slow for me right now… My install is now sitting on “Starting to Install process. This may take several minutes…” screen. I 'm in a 100 Mbps connection. How long should I wait? I wish there was a progress bar somewhere.

Unable to retrieve

Now what?

Unable to retrieve

Verified DNS, I can pull stage2.img with a web browser with no problem. Pulling from a new HP server during install it keeps failing to download stage2. Watching the console, it pulls the other images fine.

UPDATE: after the timeout, it gave the prompt to manually enter the mirror. After accepting the defaults it continued installing normally.

I’ve tried installing about four different distro’s since last night and they all seem to hang. I’ve had the server hooked to three different internet connections and installed VMware and tried to install as a virtual machine.

Last night and this morning, it would download the stage2.img file but then sits at screen “Starting Install Process, This may take several minutes”.

Now this afternoon and tonight, it sits and hangs before the “download stage2.img file” comes up.

Are the servers very overloaded?

Same problem here.
Also an error after long time waiting stage2.img.
Trying to make an Iso cd here with compleet install.
Example. Elastix installs with me in less than 2 minutes.

Ping latency on yum.freepbx.distro are very slow and time out constantly. Have tried several times and netinstall never downloads packages. Hours spent on this.