Llamadas entrantes se cortan a los 30 segundos

asterisk
Tags: #<Tag:0x00007fafc5d29a70>

(Adalbikerboy) #1

Buenas buenas…

Tengo el problema de que solo las llamadas entrantes se cortan a ls 30 segundos, estuve investigando y al parecer es un tema de NAT, uso firewlld pero no encuentro el problema y por ende la solución, en el CLI de Asterisk me manda lo siguiente al cortar la llamada…

Cabe mencionar que tengo telefonía SIP.-

Cli.-

-- Channel PJSIP/metroC-00000006 left 'simple_bridge' basic-bridge <92010c3f-9ef8-477d-805d-0484d27964f1>

== Spawn extension (macro-dial-one, s, 56) exited non-zero on ‘PJSIP/metroC-00000006’ in macro ‘dial-one’
== Spawn extension (macro-exten-vm, s, 14) exited non-zero on ‘PJSIP/metroC-00000006’ in macro ‘exten-vm’
== Spawn extension (ext-local, 3507, 2) exited non-zero on ‘PJSIP/metroC-00000006’
– Channel PJSIP/3507-00000007 left ‘simple_bridge’ basic-bridge <92010c3f-9ef8-477d-805d-0484d27964f1>
– Executing [h@ext-local:1] Macro(“PJSIP/metroC-00000006”, “hangupcall,”) in new stack
– PJSIP/3507-00000007 Internal Gosub(crm-hangup,s,1) start
– Executing [s@crm-hangup:1] NoOp(“PJSIP/3507-00000007”, “Sending Hangup to CRM”) in new stack
– Executing [s@crm-hangup:2] NoOp(“PJSIP/3507-00000007”, “HANGUP CAUSE: 16”) in new stack
– Executing [s@macro-hangupcall:1] GotoIf(“PJSIP/metroC-00000006”, “1?theend”) in new stack
– Executing [s@crm-hangup:3] ExecIf(“PJSIP/3507-00000007”, “0?Set(__CRM_VOICEMAIL=)”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [s@crm-hangup:4] NoOp(“PJSIP/3507-00000007”, “MASTER CHANNEL: 1575063628.7 = 1575063624.6”) in new stack
– Executing [s@crm-hangup:5] GotoIf(“PJSIP/3507-00000007”, “1?return”) in new stack
– Goto (crm-hangup,s,8)
– Executing [s@crm-hangup:8] Return(“PJSIP/3507-00000007”, “”) in new stack
== Spawn extension (from-internal, , 1) exited non-zero on ‘PJSIP/3507-00000007’
– PJSIP/3507-00000007 Internal Gosub(crm-hangup,s,1) complete GOSUB_RETVAL=
– Executing [s@macro-hangupcall:3] ExecIf(“PJSIP/metroC-00000006”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [s@macro-hangupcall:4] NoOp(“PJSIP/metroC-00000006”, "PJSIP/3507-00000007 montior file= ") in new stack
– Executing [s@macro-hangupcall:5] GotoIf(“PJSIP/metroC-00000006”, “1?skipagi”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [s@macro-hangupcall:7] Hangup(“PJSIP/metroC-00000006”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘PJSIP/metroC-00000006’ in macro ‘hangupcall’
== Spawn extension (ext-local, h, 1) exited non-zero on ‘PJSIP/metroC-00000006’
– PJSIP/metroC-00000006 Internal Gosub(crm-hangup,s,1) start
– Executing [s@crm-hangup:1] NoOp(“PJSIP/metroC-00000006”, “Sending Hangup to CRM”) in new stack
– Executing [s@crm-hangup:2] NoOp(“PJSIP/metroC-00000006”, “HANGUP CAUSE: 16”) in new stack
– Executing [s@crm-hangup:3] ExecIf(“PJSIP/metroC-00000006”, “0?Set(__CRM_VOICEMAIL=)”) in new stack
– Executing [s@crm-hangup:4] NoOp(“PJSIP/metroC-00000006”, “MASTER CHANNEL: 1575063624.6 = 1575063624.6”) in new stack
– Executing [s@crm-hangup:5] GotoIf(“PJSIP/metroC-00000006”, “0?return”) in new stack
– Executing [s@crm-hangup:6] Set(“PJSIP/metroC-00000006”, “__CRM_HANGUP=1”) in new stack
– Executing [s@crm-hangup:7] AGI(“PJSIP/metroC-00000006”, “sangomacrm.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/sangomacrm.agi
– Remote UNIX connection
– Remote UNIX connection disconnected
– <PJSIP/metroC-00000006>AGI Script sangomacrm.agi completed, returning 0
– Executing [s@crm-hangup:8] Return(“PJSIP/metroC-00000006”, “”) in new stack
== Spawn extension (ext-local, h, 1) exited non-zero on ‘PJSIP/metroC-00000006’
– PJSIP/metroC-00000006 Internal Gosub(crm-hangup,s,1) complete GOSUB_RETVAL=

espero puedan guiarme en este problema, gracias de antemano.


#2

Tienes correctamente configurados los valores de red referidos a NAT en FreePBX? Has revisado tu dispositivo de NAT para verificar que no haya un NAT SIP helper interfiriendo?


(Adalbikerboy) #3

Hola Ariel buen día.

Me puedes explicar un poco mejor a que te refieres con Tener correctamente configurados los valores de red referidos a NAT ? Del dispositivo NAT, es el mismo, tengo 3 tarjetas configuradas
1.- con el Internet, 1.1.1.1. ip publica,
2.-Red privada, 192.168.3.254
3.- Con telefonía, 2.2.2.2 las máquinas actualmente salen sin proxy.

Estoy usando Firewalld y mi zona por default es la Externa, pienso cambiarla a Publica.

Me imagino que como está en Externa salen las máquinas sin problema a internet.

Tendrás algún link de ejemplo que me guié a tu pregunta?, Gracias de antemano.


#4

Asterisk tiene valores de SIP referidos a la red que intervienen cuando hay NAT. Dichos valores son los que están en SIP Settings y definen la red local y la IP pública y privada. Puntualmente cuando hay una vpn site2site debes definir cómo local la red LAN remota en SIP Settings.


(Adalbikerboy) #5

Entiendo… La configuracion de sip en Settings
1.-External Addres mi ip publica
2.- mi ip privada
3.- vpn
4.- Telefonia

mi /etc/asterisk/sip.conf solo viene así


(Adalbikerboy) #6

Hola buena tarde, solo para comentar que ya quedo… era poner la ip externa SIP en el modulo de asterisk settings SIP, la ip externa de teléfonia no la que te da internet… muy sencillo, lo raro es que con un route -n decia que si salia por el gateway correcto, muchas gracias.