Linux Boot Issue


(Paul Hadley) #1

My apologies if this turns out to be a dumb question, but I am no Linux expert and despite the many FreePBX installs I have never had a Linux issue until today.

Did a FreePBX 15.0 install yesterday, restored a FreePBX 12.0 back up to and did all the relevant module and PJSIP updates I needed, all good.

Logged onto the console and got a notice updates were waiting so I ran “yum update” as instructed.

Now I have the following option as it boots.

39

The problem is the top option, which the system default boots to fails to boot stopping at this screen.

32

When I intervene and select the lower (2) option the system boots fine and everything works great?

My questions are:-

How can I remove this option so the PBX starts without intervention, there is an option to “edit” on the blue screen but then obvious way to delete option (1).

How can I ensure the system doesn’t do an automatic update in future and the problem comes back?


(Lorne Gaetz) #2

After booting from the working kernel, run

yum reinstall kernel

and then boot again from the new kernel to see if issue is resolved.


(Paul Hadley) #3

Thanks for the reply, as you were sending it I chanced it and deleted all the 19.1 reference files from the boot folder and edited the /boot/grubs/grub.cfg to remove the references to the 19.1 files.

I wouldn’t fancied chancing that on a live system !! However it has worked and its now booting without any intervention.

Also ran yum update from the console to make sure the problem didn’t return but all was well.

So a little Linux knowledge gained to day. But again thanks for taking the time to reply.


(Paul Hadley) #4

Just out of interest are the kernel file updated regularly in FPBX as part the automatic update process? and as I know understand old versions are kept for safety if they are updated how many old versions are kept?