Linksys SPA 3102 pstn trunk


(Erdei Dominik) #1

Hello! I have a Linksys SPA3102 as a pstn trunk added to freepbx with a pjsip trunk. All of the calls are working correctly (inbound and outbound), but I cannot make the caller id working. If I enable pstn cid for voip cid on 3102, I’m not get the inbound caller number at freepbx, I get only an annonymous. The inbound number is coirrectly displayed at the 3102 status->last caller field. What can be the problem?


#2

In the SPA, confirm that PSTN Answer Delay is set to at least 4, to allow time for the caller ID to be received, before starting the VoIP call.

If that doesn’t help, in Asterisk SIP Settings -> Chan PJSIP Settings -> Endpoint Identifier Order, try swapping the positions of username and auth_username, then restart Asterisk.

If no luck, please post:

Does SPA register to Asterisk, or is it statically configured?
Are you using the Line 1 port of the SPA as an extension?
Is the SPA on the same LAN as the PBX, or is it remote?
If remote, are there any other VoIP devices on the same IP address?
What country is the SPA in? What is it connected to (copper POTS line, cable MTA, fiber ONT, etc.)?


(Erdei Dominik) #3

The pstn answer delay is 5, if I change the order the extensions can’t register. The spa is registers, and this is successful. The calls works correctly, only the caller id not working. I’m using the line 1, and it is also working. The spa is on the same lan, and it is on a Hungarian pstn line. The line is connected to a cable MTA.