Linking two PBX's together

Hi All,
I have spent 2 weeks teaching myself from the ground up how to install & configure FreePBX, with a good amount of success. - I’m trying to prove a concept for where I work.

I now am trying to link two PBX’s together so that Box 1 can call 600 and it rings on box 2. Then I want box 2 to call 4897 on box 1 and it ring. All as if it was occuring on one box.

I made the configurations and i get a message saying “All circuits are busy now, please try your call again later”. I cannot work out why. - Looking at the reports, the trunks are online.

The config I have i borrowed from this video CLICK HERE - There is an additional video which i’ve used which adds one line to the config.

The Configs are as follows

BOX 1 - OUTBOUND
username=xxx
fromuser=xxx (same as username)
type=peer
secret=MY PASSWORD HERE
qualify=yes
host=BOX 2 IP ADDRESS
context=from-trunk
disallow=all
allow=gsm&ulaw

BOX 1 INBOUND
User Context username as above

type=user
secret=MY PASSWORD HERE
host=BOX 1 IP ADDRESS
context=from-trunk
disallow=all

Then for box 2 - I have done the reverse.

In the outgoing routes I have added the trunk and in the dial pattern i’ve put 6XX on box one where if it sees a 6XX number it should dial that trunk

and done the same for box2 where 4XXX is the same.

Please respond to me in simple terms , any help is appreciated.

You are showing settings for chan_sip, which is obsolete and not recommended for new systems. You should be using pjsip instead.

Be aware that the default settings on recent systems have pjsip Port to Listen On = 5060 and chan_sip Bind Port = 5160.

If you don’t specify a port in your trunk settings, it defaults to 5060, so your chan_sip outbound trunk is likely reaching pjsip on the other system, which has no configuration and is rejecting the call.

You can do any of:

  1. Use pjsip trunks.
  2. Use port=5160 to reach chan_sip on the remote end.
  3. Change Bind Port to 5060, after changing Port to Listen On to something else.

Hi,

Try using IAX trunks between the two servers.

Study the images below for config for both servers.
NB: Ensure that extensions on each server do not clash in any way.

Your outbound route seems fine. You could also share screenshots so we can have a look.

Cheers…

Attached are what I have thus far:- not working though. So I will read through comments and see if i can make changes.


You definitely should use chan_pjsip, but with chan_sip, you don’t need peer and user entries. There should just be peer entry, with type=peer. Separate entries are only sometimes needed, to work round limitation of chan_sip, but this should be a simple case. Your user section won’t work without fromuser on the other side, but fromuser introduces unnecessary complications with caller-ID.

username does nothing when you have a static address.

If you do have two entries, they should both be for the same context, which should be from-internal, for an intra-company trunk.

password1 and password2 must be the same. To reliably separate them you definitely need chan_pjsip.

So, an update

Using the existing outbound route config (unchanged) but changing the inbound as per Grace pictures. I can get BOX 1 to call the extns on BOX 2. However, using identical config (except IP changes) I cannot get the BOX 2 to call BOX 1.

Everything looks the same and correect.

Try taking a closer look.

Such happens if there is perhaps an error somewhere.

Best of luck.