FreePBX | Register | Issues | Wiki | Portal | Support

Letsencrypt cert with pacemaker 2 nodes freepbx cluster

freepbx
bug
configuration
Tags: #<Tag:0x00007fafc57964f0> #<Tag:0x00007fafc5796388> #<Tag:0x00007fafc5796248>

(Renato Gallo) #1

Hello,

Got two nodes with a failover ip.
The A record points to that failover ip.
I have generated a letsencrypt-auto -d machine certificate on the master node.
On the master node all is working well.
On the slave node I have SSL Library Error: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch and apache doesn’t start.
keys and apache confs reside on a drbd volume shared between the two nodes (so are equal for both nodes).
If I disable ssl apache starts without problems.

Help please