Let's Encrypt cert for UCP?

I currently have UCP on port 80 of our PBX and admin on 81. If i visit https://pbx (self signed cert) I’m redirected to the admin page. When I try and enable Let’s Encrypt the tokens never fully pass through. Is it because it’s expecting admin on port 80?

Ultimately I’d like the UCP to be using https and admin on a separate port.

You need to set your https ports in System Admin. If you don’t have system admin, you’ll need to fix it manually in ssl.conf.

Don’t forget to go into Certman and set it to default. That assigns the LE cert to all the additional services.

1 Like

Thanks for the information Rob, the last time I had looked at SysAdmin i didn’t see the HTTPS tab. I’m still having trouble creating the Let’s Encrypt Certificate. I opened http and https for any to this server and was able to reach http and https using my self signed cert. (ports are closed at the moment) When I tried to sign up for Let’s Encrypt I got this error though.

I browsed to the token link and returned back a webpage with the token key.

Not sure why the cert manager wouldn’t be able to get the token.

tested from several different computers on different ISP and was able to reach the site each time.

That error is from letsencrypt. Maybe they don’t know about the .center top level domain yet?

switched host names to a different domain,

There was an error updating the certificate: Please check http://server.food3point0.org/.well-known/acme-challenge/tEMzBH4NcCdAF6XJ1OSBBZwMXV8hH3… - token not available

Not Found

The requested URL /.well-known/acme-challenge/tEMzBH4NcCdAF6XJ1OSBBZwMXV8hH3 was not found on this server.

I am also getting the same error, using a .com domain name. Ever figure out what was wrong?

For me, the system hostname wasn’t matching (System Admin / Hostname) the common name of the Certificate i was requesting.

1 Like

That did it. Thanks!


Now the cert won’t install thought… odd…

Need way more details on what you mean to be useful

Yeah, sorry.

So the cert was able to generate in the cert manager, i assigned it to default then went to HTTPS setup, then in the settings tab i select the cert and click install then this comes up:

Apache Config: No Certificate in Apache config
Certificate Name:
Certificate Issuer:

There are no error messages or anything.

Please make sure you are on the latest edge release.

I just upgraded to 10.13.66-14 and still have the problem.

Please make sure you are on the latest edge modules.