Let's Encrypt cert expiring soon - auto renew not working?

Latest FreePBX 16.0.39 installed with the Let’s Encrypt cert about a year ago. Setup the appropriate firewall settings (used the defaults and the responsive firewall) and forwarded port 80 for Let’s Encrypt only - all worked great.
Recently got an email from [email protected] indicating the cert is going to expire in less than two weeks and checked the cert manager and verified that. I was under the impression FreePBX would auto-renew it. Any idea what logs to check to see why it is not? Also not seeing any warnings in the dashboard.
I searched the forums and have found a few users with this issue but would prefer not to renew manually but will if I have to. Rather find out the issue with auto-renew.

It seems to be a known issue as many have already posted on the topic here.

Posting to say that I’ve seen this on three of the systems we manage. Manual renew worked just fine, auto-renew was about to let the cert expire.

OK. One thing I did notice is the cert has renewed in the past, about 3 months ago. Perhaps it waits until the last day to renew it (I may wait and see). If I do it manually did you just hit Update Certificate in the Cert Manager or use the command line?

It’ll work off and on automatically and nobody seems to know the reason as to why it’s not when it doesn’t.

I typically do a ssh <hostname> fwconsole cert --updateall

Auto.cert update hasnt worked since Janusry for me…hitting update cert in the webadmin gui also didnt work… had to updste manualling via ssh as noted above

Has anyone filled an issue yet?

I noticed this issue on a few of my managed servers as well for the past year I think. Manually updating works, but at the end of that 3 month time frame, it was the same problem again. I recently found out that by deleting the certificate and recreating a new one, this fixed my auto renew issue with those particular servers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.