Legacy EPBX Outbound NO MATCH or Dial Tone, inbound works

Hi,

I’m using FreePBX distro
Asterisk 13.9.1
freepbx-13.0.127 with no customizations.

I have created two trunks and mapped one to PRI Line while the other goes to Legacy PBX from Syntel.

Inbound calls work fine but their legacy PBX uses “press 0” to get outbound lines.

I have tried various combinations of dial plan with and without caller id match but I keep getting following output in asterisk:

Accepting call from ‘3355112212’ to ‘s’ on channel 0/31, span 3
– Executing [[email protected]:1] NoOp(“DAHDI/i3/3355112212-49”, “No DID or CID Match”) in new stack
– Executing [[email protected]:2] Answer(“DAHDI/i3/3355112212-49”, “”) in new stack

I suspect that legacy pbx is sending each digit to FreePBX and therefore calls not connecting.

Kindly help.

There’s another guy asking almost exactly this same question about three items down on the list. Maybe the two of you should get together and try to figure out what the other one is doing.

1 Like

check that you don’t have

immediate=yes

in your dahdi trunk

1 Like

Under Dahdi Config > Global Settings > Answer immediately
This is set as NO.
Are you referring to the same one ?

I checked the chan_dahdi.conf from cli, immediate=no.

then it shouldn’t go to extension s it should go to the mtching extention of the context you chose

http://www.voip-info.org/wiki/view/chan_dahdi.conf

Thanks Dicko but under the Asterisk dialplan special extensions:
It says
s: Start extension : When an analog call comes into Asterisk, the call is sent to the s extension.
https://wiki.asterisk.org/wiki/display/AST/Special+Dialplan+Extensions

I’m even using X. to try and catch the call but no luck.

I have found this thread,


but when I put “w” or “W” in any of the trunk or outbound prefix,
I get error pop-up, invalid dialplan.

After going through few posts, it seems that asterisk starts dialing number immediately and legacy epbx have to Wait for entire string to be punched once dial tone is heard.

Any suggestions?