Legacy Backup/Restore: Extensions can't register


I’m really desperate and need your help with this…

I just restored a legacy backup from FreePBX to a freshly installed FreePBX The process was finished without errors and all settings were adopted.

The issue: the restored extensions can’t register. I’ve added some new extensions for testing and these can register without any problems.

I’m always getting these log messages when trying to register with a restored extension:

[2020-08-20 09:45:40] SECURITY[10152] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="2020-08-20T09:45:40.258+0200",Severity="Informational",Service="PJSIP",EventVersion="1",AccountID="35",SessionID="iek71ez.9u",LocalAddress="IPV4/UDP/",RemoteAddress="IPV4/UDP/",Challenge=""
[2020-08-20 09:45:40] NOTICE[10104] res_pjsip/pjsip_distributor.c: Request 'REGISTER' from '<sip:[email protected]>' failed for '' (callid: iek71ez.9u) - Failed to authenticate
[2020-08-20 09:45:40] SECURITY[10152] res_security_log.c: SecurityEvent="ChallengeResponseFailed",EventTV="2020-08-20T09:45:40.278+0200",Severity="Error",Service="PJSIP",EventVersion="1",AccountID="35",SessionID="iek71ez.9u",LocalAddress="IPV4/UDP/",RemoteAddress="IPV4/UDP/",Challenge="1597909540/029091a19bef955b3a79414f6fc87206",Response="e0847f5ec9b82260f514e3f78bf6ec1c",ExpectedResponse=""

If I try the same phone with a newly created extension, it is able to register:

[2020-08-20 10:12:56] SECURITY[10152] res_security_log.c: SecurityEvent="ChallengeSent",EventTV="2020-08-20T10:12:56.670+0200",Severity="Informational",Service="PJSIP",EventVersion="1",AccountID="35",SessionID="ejt1a3cvgy17fydo0pnf92afqyq",LocalAddress="IPV4/UDP/",RemoteAddress="IPV4/UDP/",Challenge=""
[2020-08-20 10:12:56] SECURITY[10152] res_security_log.c: SecurityEvent="SuccessfulAuth",EventTV="2020-08-20T10:12:56.691+0200",Severity="Informational",Service="PJSIP",EventVersion="1",AccountID="35",SessionID="ejt1a3cvgy17fydo0pnf92afqyq",LocalAddress="IPV4/UDP/",RemoteAddress="IPV4/UDP/",UsingPassword="1"
[2020-08-20 10:12:56] VERBOSE[10104] res_pjsip_registrar.c: Added contact 'sip:[email protected]:5060;line=48266' to AOR '35' with expiration of 3600 seconds
[2020-08-20 10:12:56] VERBOSE[10104] res_pjsip/pjsip_configuration.c: Endpoint 35 is now Reachable
[2020-08-20 10:12:56] VERBOSE[10104] res_pjsip/pjsip_options.c: Contact 35/sip:[email protected]:5060;line=48266 is now Reachable. RTT: 35.166 msec

I’ve tried with different SNOM phones and softphones, I’ve tried to turn off the firewall, I’ve tried with SIP instead of PJSIP, I’ve checked the config files for differences - unfortunately without success.

Any ideas what could cause this behavior? Are there any “hidden” settings that are not applied during a legacy restore?

Thanks a lot in advance!

Are your legacy extensions chan_sip? Because they are being rejected by the pjsip driver. If the restore changed your port bindings, you need to restart asterisk for the changes to take effect:

fwconsole restart

I’ve tried with both SIP and PJSIP, I’ve tried different ports and I restarted like 1000 times.

Edit: I even tried to delete a legacy extension and create it again. Same behavior… :confused:

Finally found the solution!

I’ve changed the “Endpoint Identifier Order” under “Settings > Asterisk SIP Settings > SIP Settings [chan_pjsip]” to this:

[username] [ip] [anonymous] [header] [auth_username]

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.