Kickstart error, can't find eth0, but I do have p2p1

I downloaded and tried to install Stable-1.1009.210.62 and after the network parameter config screen it came up with an error about kickstart not being able to find device eth0.

I hit alt-f2 to get a console and ifconfig showed a p2p1 ethernet device.

After a bit of googling, I found that Centos / Redhat has started using different device naming.

I found a kernel boot param to turn off the new names: biosdevname=0. (used at the kernel boot screen, ie. “freepbx-noraid biosdevname=0”)

That has allowed me to get past that error. Dunno if any other issues will pop up later, I’m still in the middle of installing.

Just wanted to put the full error here for future googling:

The following error was found while parsing the kickstart configuration file:

The following problem occurred on line 13 of the kickstart file:

The provided network interface eth0 does not exist

And the only button available is “Reboot”.

p2pl is a firewire port I think. That won’t work too good.

You might need to run the CentOS 6 beta to get a driver for your eth port

For what it’s worth, I had the exact same error attempting to install the same version on a Dell T110 last night. Stable EOL-1.817.210.58 installs fine. I assume it’s a 6.2 driver issue but I’m curious what hardware you were using. Would you share?

Nope, its not firewire. Just the new naming scheme in recent Redhat / Centos.

Sure. This is an old spare Dell Optiplex GX620 I had kicking around.

Its pretty ancient.

I just had the exact same issue on a Dell Poweredge R320, brand new out of the box. From what I’ve ready, this seems fairly common to Broadcom NICs.

Thanks for the tip on the boot parameter change. It’s working now.