Keeping O/G Calls to a specific Trunk or Route

Hi Guys, I have a problem that’s driving me nuts. I have two SIP Trunks each belonging to two independent outgoing trunk groups. I have extensions that belong to one or the other outgoing routes, but no extension belongs to more than one outgoing trunk group.

My problem is, outgoing calls from any extension seem to be going out of the first outgoing trunk group. i.e. the Caller ID of the first outgoing trunk group is always displayed on the called party phone. If I swap the order of the outgoing trunk groups in /admin/config.php?display=routing the Caller ID of the first route is always displayed on the called party phone.

How do I ensure that calls from a given extension go out on a pre defined route only and not all calls go out to the first route as I have at the moment.

You can use the caller id match in outbound routes or the class of service module.

Can you give me more details regarding " caller id match" in out bound routes please?

Would that be in “Extension Routes” my system says that “The free Extension Routes module is installed, but not registered.” But it’s installed under Modules Admin ?

So how does one install/activate the Extension Routing Module ??

You will need to register your deployment. See the wiki.

Thanks, I’ve now done that, what happens next, how do I get it installed?

There is a lot more info in the wiki. Search on “Extension Routing”

You might start here.

OK I must be missing a trick here. I have registered my deployment but my system still says “The free Extension Routes module is installed, but not registered.” I have followed your link to to the wiKi page but it’s a blank page with links to a video and a user guide which assumes you already have Extension Routes up and running. All I’m trying to do is register my Extension Routes so I can start using it. I guess I could hack around in asterisk .conf files but I’d rather not do that unless I really have top. Can anyone tell me what am I missing?

@TheJames I dont have the Class of Service Module and I don’t see anything in Outgoing Routes that will allow me to perform a caller id match. I just want all calls from extensions 200 and 201 to go out over Outgoing Route “A” and that route only and all calls from extensions 100-104 to go out over Outgoing Route “B” and “B” only. That way the correct caller id will always be presented to the called party. I’m not sure why this is so hard?

It is really not that hard.

Why don’t you just specify the “Outbound CID” for each of the extensions you want to have a particular CID? There is no need for 2 routes. Just put the CID in the “Outbound CID” field of x200 and x201.

@Taffman once you register your deployment, you will need to go into the portal store, add extension routing to your cart and check out, where you will select the deployment that you created, then go back into FreePBX GUI, SysAdmin>License and check for new licenses. This is what applies the license to your system.

@alan, “Outbound CID” has never worked for me. I think my SIP provider is ignoring any CID overide and applying the CID allocated by them.

@reconwireless I’ve logged to the portal but I only see chargeable packages that I can order. Extension Routing is nowhere to be seen?

@Taffman You should be able to locate this under FreePBX Software in the portal store.

Once there, you have options for Software Bundles, Commercial Modules, and Operator Panels.

Go to the Commercial Modules section, and you should see the FreePBX-CM-Extension Routing Module 25 Year License

If your carrier is ignoring your CID override there is no FreePBX module that will help you. You first need to verify that your carrier will let you change the CID.

@TBryant I don’t see that there at all. It appears that “FreePBX-CM-Extension Routing Module 25 Year License” is not available to me ?

After finding a new pair of specs, I eventually found it. Thanks to everyone who took the time to help out here.