Ivr wont allow multi digit options

ivr wont allow multi digit options. trying to have an option 5570 point to a misc destination which is a pstn number…when i use single digit option it work fine,but when using a multi digit option it says "we have not received a valid response. this had always worked in the past…not sure what has changed?


Have you enabled “Enable Direct Dial” in your IVR (that’s with FreePBX 13, I am not sure if it has exactly this name in previous versions)?

Have a nice day!


yes…direct dial is enabled…will not work with it set to extension or set as directory with custom entry matching digits dialed. even tried adding a custom extension and no change

after trying multiple routing scenarios…(all actually worked) I discovered that if dialing slower at IVR prompt the call would complete to any target, ie misc destination, ext on iax trunk to remote system , etc…

for some reason slow and deliberate key presses works every time and even moderately faster the call will fail saying “we did not receive a valid response”…

Any suggestions on how to address this would be greatly appreciated (DTMF recognition sensitivity?)

I had outgoing callers tell me they had some trouble dialing other auto attendants and digits being recognized and when they dialed slower it worked.

I know that for my DAHDI extensions I had to set relaxdtmf=yes to get my FreePBX box to correctly process the DTMF digits…

It my case it was done at the channel level but I think you can set that at the SIP level too (ie “Other SIP settings”).

Good luck and have a nice day!