IVR stops excepting input numbers but answers everytime

I have a box in service for quit awhile with no problems, 3-lines coming in and one being answered by an IVR. Today the IVR stop taking input, 1 for sales, 2 for service … It would answer everytime but would not except any input. Tried a reload of asterisk, no effect, tried stopping and restarting asterisk, no effect. Rerouted incoming calls to a ring group until I can reboot the machine. CPU shows no loads and is running cool.

Has anyone seen this problem, is there a fix?

Many people have complained of something like this but due to the total lack of real details it’s hard to tell you where to start.


So provide details so we know what you have as a setup, trunks, etc. and I’m sure somebody can respond. But for example how you deal with IVR input on a Zap channel is different then for a SIP channel. Yes it’s a dtmf issue but what files you edit, etc are different.

So please help us help you.

It turns out the sip trunk provider changed their internal settings over the weekend which made it necessary to change the settings in sip trunks in user details, dtmfmode to auto from inband. Everything is working, thanks.