IVR Problems

I have an IVR setup for all calls to my main number. There are several options on the ivr 1, 2, 3 and I enabled dial ext directly. When a calls gets to the IVR menu they are not able to dial any extension directly (4 digit exten #). I have tried enabling strict timeout (as well as disabled it). I have added 2 extensions as IVR options (9291 and 9292) and still not working. It appears that about 1 in 5 times or so it works the rest of the time it plays a message “we have not received a valid response”. I set the timeout to different values, turn on and off strict timeout still very random results? My pbx version is FreePBX, the ivr app is

The issue appears to be more prevalent if I call the IVR from this or another freepbx, not so often with an analog line.

Whats the dtmf mode set to? Why are you hitting pound? But turn dtmf logging on. And check your dtmf mode between the freepbx trunks.

if rfc3833 or 4877 doesnt work try inband.

As @partgenius says. Some additional info:

First, confirm that DTMF works reliably in non-IVR applications, e.g. entering voicemaill passwords.

In Settings, Asterisk Logfile Settings, turn on DTMF for ‘full’.
In the IVR, set Force Strict Dial Timeout to No - Legacy and set Timeout to 6.
Make some test calls, entering an extension number where all four digits are different.
Initially, try entering the number right after the Announcement has completed.
If this doesn’t fail, enter the number while the Announcement is playing.

Paste two logs, one for a failure and one for success at https://pastebin.freepbx.org and post the links here.

When calling from your own PBX, are you going out one trunk and in another? If so, try setting up a Misc Application for the IVR, so you can call it directly from your extension. Report whether that works reliably.

not hitting pound, that was 4 digit exten # (i.e. 4 digit extension number). I had debugging running at the time and I saw “accepting a maximum of 1 digit” in the log at the ivr prompt? I have 1 and 4 digit options in the menu.

DTMF is rfc2833 (default?, I have never changed it)

My phone has numbers on 3 different PBX systems. Mine and 2 customers systems. This is so I can better monitor system outages. I was calling from one pbx to another. The call would have been going out to my sip provider and back in to other pbx from the same provider (same provider/trunk the analog calls come in to). I have noticed that when it works on a call it works for all prompts, when it doesn’t work I can not dial any option no matter how many times I try. (i.e. its not failing once and then accepting, i can repeat the options in the silence after the message and nothing works, 1 digit or 4 digits.)

I have no reports from users dialing in remotely to the main number (i.e. analog number outside my pbx) ever having an issue. I will paste logs when I get time to run the tests again with the debugs turned on.

Try setting DTMF to auto on your outbound trunks and inbound. If that doesn’t work try inband. On both PBX’s. Just to isolate that as an issue. What type of endpoints are you using on the remote side? Some do not properly support rfc2833.

Actually try inband first and then auto.

I am dialing out on a grandstream gxp2170

Ok so on the grandsteams under audio settings what do you have for send dtmf? It lets you check multiple boxes.
Basically there are DTMF options in multiple places
-Outbound Trunk
-Inbound Trunk
-The actual carrier processing the audio on both outbound and inbound trunks.

RFC2833 or the pjsip variant does not send over the audio channel
In-Band sends over the audio channel but is subject to glitches with G729 and latency/jitter.
Auto uses 2833 and falls back to In-band if the carrier doesn’t advertise support for 2833 but it’s not perfect.

Sometimes the origin or term carrier will advertise support for rfc2833 but then send inband instead. 2833 is the preferred method among all sip providers. Sometimes using inband or auto on the trunks only will alleviate the issue. Then open a ticket with your carrier. You need to isolate if this is the issue.

Check the settings on the grandstreams obviously. I would assume if you had audio and 2833 if might be similar to auto but IDK. Info is almost never used. On the Remote and Local PBX use DTMF logging and compare the two. Is it making it from the grandstream to the PBX? If you are using G729 anywhere inband will likely have issues…or so I’ve heard.

I will check the settings as described but I use this phone all day, every day. I have never had an issue sending DTMF to any other number I dial. I use it for all sorts of automated systems like the bank, home depot, verizon, and many many more and have not once had an issue navigating anyone else’s IVR so I am suspecting something on my PBX?.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.