IVR problem - no sound

Hi,

I’ve tried the IVR functionality on FreePBX 2.3.1.0 but I cannot get the file to play when our inbound number is dialled.
I can dial the DTMF options and they go to the correct places (Extensions or Groups) but I don’t hear the specified file.
I have tried using a WAV file in the correect format, I’ve tried using sox to change it to GSM but still no sound. I’ve also tried using one of the built in sounds but they don’t play either.
When debugging Asterisk I can see it thinks it’s playing the file…

I’ve even now tried recording using an extension (*77) but still I don’t hear anything when dialling in :frowning:

Any thoughts?

Many thanks.

1 Like

I’ve heard of other people having the same problem, but I’ve never been able to replicate the problem. If you find the solution, please post it here.

Please help me on how to configure my IVR. I use freepbx version 2.6.0.5.things done so far are created my extensions and can make calls with my sip phones.Inform me on what to do. Thanks

google for “trixbox without tears” for trixbox 2.4. I don’t think they produced a 2.6 yet and it is almost identical to the 2.4.

try using Digium website to convert your file GSM or WAV

http://www.digium.com/en/products/ivr/audio-converter.php

good luck

Howdy… fresh install of 2.6… using voicepulse as my vendor… if I set up an inbound route to an extension the call goes through no problem. When I use an IVR receptionist I get dead air. I recorded the voice using *77 and when I go to system recordings it is there and I can play it. But can’t get ivr to work.

Any help?

Thanks

D

but no luck through voicepulse… even though when connected to just an extension voicepulse works just fine…

hmmmmm

Thanks for any help

D

I found my problem was with codecs. The system was trying to use G729 but because I didn’t have the licence it wouldn’t play.
After I moved to G711 all the sounds played without any problems.

I’m using the codecs that VoicePulse set up for automatically:

allow=ulaw&alaw&gsm&ilbc&g726&adpcm&lpc10

And when I set it up to go directly to an extension the voice comes over just fine

I’ve now set up several different IVRs with sounds from a variety of different sources and I can get none of them to play over the voicepulse line but 7777 works just fine.

Arrrg…

Dave

Have you tried looking at CLI when dialling in to the IVR? Have a look to see if it thinks it’s playing the file or maybe it’s a permissions issue can it can’t actually open the file…

Looking at the logs it creates no error… just says its playing the file.

Dave

not sure but check this. Since TB 2.2.11 and on up the OSLEC echo cancelation is compiled in. So take a look at your /etc/asterisk/zap*.conf files and comment out the echotraining= line. If that is enabled it attempts to use two echo canceling routines and somehow that stops all data from flowing giving you dead air.

Hey… thanks for the response…

I grepped for echotraining and found it in the zapata.conf file. It was already commented out so I tried uncommenting it/// no luck… then I tried setting it to ‘no’… nada

Nothing is working. Arrrrrrg

D

OK… I’m posting the logs for both calls

This one is dialing 777 from an extension… the sound works fine

[Apr 11 02:04:31] WARNING[18730] rtp.c: Unable to set TOS to 184
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:1] Goto(“SIP/101-08c72da0”, “from-pstn|s|1”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Goto (from-pstn,s,1)
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:1] Set(“SIP/101-08c72da0”, “__FROM_DID=s”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:2] Gosub(“SIP/101-08c72da0”, “app-blacklist-check|s|1”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:1] LookupBlacklist(“SIP/101-08c72da0”, “”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:2] GotoIf(“SIP/101-08c72da0”, “0?blacklisted”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:3] Return(“SIP/101-08c72da0”, “”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:3] GotoIf(“SIP/101-08c72da0”, “1 ?cidok”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Goto (from-pstn,s,5)
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:5] NoOp(“SIP/101-08c72da0”, “CallerID is “device” <101>”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:6] Goto(“SIP/101-08c72da0”, “ivr-2|s|1”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Goto (ivr-2,s,1)
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:1] Set(“SIP/101-08c72da0”, “LOOPCOUNT=0”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:2] Set(“SIP/101-08c72da0”, “__DIR-CONTEXT=default”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:3] Set(“SIP/101-08c72da0”, “_IVR_CONTEXT_ivr-2=”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:4] Set(“SIP/101-08c72da0”, “_IVR_CONTEXT=ivr-2”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:5] GotoIf(“SIP/101-08c72da0”, “0?begin”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:6] Answer(“SIP/101-08c72da0”, “”) in new stack
[Apr 11 02:04:31] VERBOSE[18826] logger.c: – Executing [[email protected]:7] Wait(“SIP/101-08c72da0”, “1”) in new stack
[Apr 11 02:04:32] VERBOSE[18826] logger.c: – Executing [[email protected]:8] Set(“SIP/101-08c72da0”, “TIMEOUT(digit)=3”) in new stack
[Apr 11 02:04:32] VERBOSE[18826] logger.c: – Digit timeout set to 3
[Apr 11 02:04:32] VERBOSE[18826] logger.c: – Executing [[email protected]:9] Set(“SIP/101-08c72da0”, “TIMEOUT(response)=10”) in new stack
[Apr 11 02:04:32] VERBOSE[18826] logger.c: – Response timeout set to 10
[Apr 11 02:04:32] VERBOSE[18826] logger.c: – Executing [[email protected]:10] BackGround(“SIP/101-08c72da0”, “custom/mainwav”) in new stack
[Apr 11 02:04:32] VERBOSE[18826] logger.c: – <SIP/101-08c72da0> Playing ‘custom/mainwav’ (language ‘en’)
[Apr 11 02:04:52] VERBOSE[18826] logger.c: == Spawn extension (ivr-2, s, 10) exited non-zero on ‘SIP/101-08c72da0’
[Apr 11 02:04:52] VERBOSE[18826] logger.c: – Executing [[email protected]:1] Hangup(“SIP/101-08c72da0”, “”) in new stack
[Apr 11 02:04:52] VERBOSE[18826] logger.c: == Spawn extension (ivr-2, h, 1) exited non-zero on ‘SIP/101-08c72da0’

This one is from the outside voicepulse line… I just get dead air
[Apr 11 02:07:33] WARNING[18730] rtp.c: Unable to set TOS to 184
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:1] NoOp(“SIP/from-voicepulse-08c7ae20”, “Catch-All DID Match - Found 12076186702 - You probably want a DID for this.”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:2] Goto(“SIP/from-voicepulse-08c7ae20”, “ext-did|s|1”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Goto (ext-did,s,1)
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:1] Set(“SIP/from-voicepulse-08c7ae20”, “__FROM_DID=s”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:2] Gosub(“SIP/from-voicepulse-08c7ae20”, “app-blacklist-check|s|1”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:1] LookupBlacklist(“SIP/from-voicepulse-08c7ae20”, “”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:2] GotoIf(“SIP/from-voicepulse-08c7ae20”, “0?blacklisted”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:3] Return(“SIP/from-voicepulse-08c7ae20”, “”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:3] GotoIf(“SIP/from-voicepulse-08c7ae20”, “1 ?cidok”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Goto (ext-did,s,5)
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:5] NoOp(“SIP/from-voicepulse-08c7ae20”, “CallerID is “6504750873” <6504750873>”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:6] Goto(“SIP/from-voicepulse-08c7ae20”, “ivr-2|s|1”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Goto (ivr-2,s,1)
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:1] Set(“SIP/from-voicepulse-08c7ae20”, “LOOPCOUNT=0”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:2] Set(“SIP/from-voicepulse-08c7ae20”, “__DIR-CONTEXT=default”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:3] Set(“SIP/from-voicepulse-08c7ae20”, “_IVR_CONTEXT_ivr-2=”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:4] Set(“SIP/from-voicepulse-08c7ae20”, “_IVR_CONTEXT=ivr-2”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:5] GotoIf(“SIP/from-voicepulse-08c7ae20”, “0?begin”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:6] Answer(“SIP/from-voicepulse-08c7ae20”, “”) in new stack
[Apr 11 02:07:33] VERBOSE[18845] logger.c: – Executing [[email protected]:7] Wait(“SIP/from-voicepulse-08c7ae20”, “1”) in new stack
[Apr 11 02:07:34] VERBOSE[18845] logger.c: – Executing [[email protected]:8] Set(“SIP/from-voicepulse-08c7ae20”, “TIMEOUT(digit)=3”) in new stack
[Apr 11 02:07:34] VERBOSE[18845] logger.c: – Digit timeout set to 3
[Apr 11 02:07:34] VERBOSE[18845] logger.c: – Executing [[email protected]:9] Set(“SIP/from-voicepulse-08c7ae20”, “TIMEOUT(response)=10”) in new stack
[Apr 11 02:07:34] VERBOSE[18845] logger.c: – Response timeout set to 10
[Apr 11 02:07:34] VERBOSE[18845] logger.c: – Executing [[email protected]:10] BackGround(“SIP/from-voicepulse-08c7ae20”, “custom/mainwav”) in new stack
[Apr 11 02:07:34] VERBOSE[18845] logger.c: – <SIP/from-voicepulse-08c7ae20> Playing ‘custom/mainwav’ (language ‘en’)
[Apr 11 02:07:44] VERBOSE[18845] logger.c: == Spawn extension (ivr-2, s, 10) exited non-zero on ‘SIP/from-voicepulse-08c7ae20’
[Apr 11 02:07:44] VERBOSE[18845] logger.c: – Executing [[email protected]:1] Hangup(“SIP/from-voicepulse-08c7ae20”, “”) in new stack
[Apr 11 02:07:44] VERBOSE[18845] logger.c: == Spawn extension (ivr-2, h, 1) exited non-zero on ‘SIP/from-voicepulse-08c7ae20’

When I set the inbound route to an extension and call from an outside line I hear the voicemail prompt just fine.

I have recorded the sound from a variety of sources (including freepbx) and used various utilities to convert the sound files back and forth to the suggested format

I have even bought and downloaded installed and registerred digium’s codec

I have disabled all echo cancellation in zapata.con

Anyone have anything else I can try?

Thanks for any help.

Dave

this problem is the same i am having. the server will not play any built in recordings or recorded sounds. at first i thought it was the audio format i was using so then i tried to record it from an extension. i get no audio what so ever.
the ivr functionality works - you can press extensions or buttons during the IVR (even tho you cant hear the ivr message) and the behavior is right.
there are no errors in the log and as far as the serer knows the sounds are playing as they are meant to.

here are the things we have looked at so far to try to run down the problem
codecs
ports
firewall
trunks, connectivity etc

we have a gang of freepbx servers running in openVZ containers on a centOS server. all the ones we just built are having this same issue but the ones we have in operation that are built the same way are working fine.
we can not find any difference in these builds.
It is almost like the “media” plug in/ interface(if such a thing exists) is not working. we are going to check all of our hardware settings next and cross reference them with the old box.

any other directions we can look would be great if some one has some insight

Willy,
Make sure the WAV is 8000hz and mono, not stereo. Have you tested making a recording from an extension? Still no audio?

1 Like