IVR not recognizing digits

Hi all.

Having an IVR issue with FreePBX 14.0.17. I know its not the most recent, I have upgraded all my other PBX’s but this one has a few legacy devices I am migrating before I can upgrade. System is a Distro install no customizations outside of the admin console adding trunks, extensions, IVR, and ring groups. System has all the latest patches and updates (every month, verified there is no new updates). Has worked great for years but recently I noticed that calling my main number the IVR plays but it does not recognize any digits typed and just keeps repeating “we have not received a valid response”.


  • If I call my main number from a Verizon cell phone it will NOT recognize any digits.
  • If I call from another extension on the PBX it works as expected.
  • If I call this PBX from any other PBX I operate (all use telnyx) it works as expected
  • I have verified my trunk at Telnyx is set to use allow=ulaw,alaw and dtmfmode=rfc2833
  • I have verified my trunk settings (inbound) in freepbx is set to use allow=ulaw,alaw and dtmfmode=rfc2833
  • IVR module is V14.0.9.9
  • is ONLY affecting one IVR, other IVR’s on the SAME PBX work as expected even when calling from Verizon!
  • tried yes, no, and legacy setting for strict timeout
  • there are no overlapping options (its 1, 2, 3 and extensions all starting with a 9)
  • invalid eventually goes to my voicemail
  • if I start entering digits on any other IVR the message stops immediately then and within 4 seconds choses the option based on the digits entered, for this IVR it ignores all digits and continues to play message (clearly its not hearing any tones)

I understand this may not be an IVR issue except that it works in every other way and all other IVR;s work fine. I am building a new IVR with all the same settings to see if that works.

built new IVR from scratch, same issue. Additional notes
All other IVR’s are accessed by dialing a Telnyx number directly and IVR is the inbound route option. This IVR having an issue, I don’t own the main number its a Verizon (FiOS) line that has simultaneous ring set to include a number (telnyx) that goes to my PBX directed to the IVR. The IVR always answers and plays the message.

Clearly its related to the simultaneous ring, if I call the telnyx number directly it works fine. I will now investigate the simultanious ring options with the verizon digital line.

tried forwarding to another number and new IVR same issue. Its clearly a verizon call forwarding issue. There does not appear to be any way to enable DTMF on the forwarded call. Maybe its not rfc2833 at that point?

We get this issue with call confirmation (press 1 to accept the call) turned on, it comes and goes, but would be nice to figure a way to resolve it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.