IVR in freepbx not working

I setup a IVR in Freepbx and when I call the number that has the IVR I get a message that says we have not received a valid response any ideas ?

Normally would indicate you have not pressed any options within an allotted time frame. Did you set the IVR to use an Announcement? Did you record the Announcement with the correct options? I.E. Press one to reach xxx, press 2 to reach xxx and so forth? Is direct dial on and working, if allowed?

Might be better for you to explain what you’re trying to do, so we can understand more about your IVR.

Generally this is incorrect DTMF signalling. Check what your provider supports and turn on DTMF logging to debug

I uploaded audio recording here is a screenshot http://oi49.tinypic.com/15hzgyf.jpg
and http://oi49.tinypic.com/epoku1.jpg

As I asked, you should explain what you’re attempting to get from this IVR? I am not going to guess at what you’re trying to do with it. From what I can see, you have set up the IVR to allow for direct dial, which would mean the called should know the Ext # they need to talk to. I do not know if you are dialing in the number to call the EXT or if the EXT exists or not.
You do have the settings ready to call the extensions, I can see that… Why don’t you make the options in a single digit to see if it works, like press 1 to call 1001, just to test it out and remove the direct dial, you may be confusing it with direct dial 1001 and the input for 1001. Just remove the “Direct Dial”, set it at None, set the ext options only… or better still, remove the exts at the bottom and turn on the Direct dial.
I am not at my server right now, so I can’t test this out for you, but you will have to remove one or the other.


I did what you said to do and it did not work.

Ok, I just set up a basic IVR, nothing flash.... I will include a screen shot of it. All I did was, set up my announcement - changed direct dial to extensions - left everything else but changed my invalid destination and timeout destination to terminate calls. I only did the terminate to speed things up on my end. I added NO extensions to the IVR Entries, they are NOT required if using a direct dial. I called into the IVR, got my Announcement message and directly dialed the extension I wanted.... my extension rang and did what it was meant to do.

Do you hear your Announcement when you call the IVR?

Here is the screenie.. 

Might be kind of a stupid suggestion, but did you ensure that the IVR is recorded in the proper format? It needs to be PCM Encoded, 16 Bits, at 8000Hz

Again, just a thought.

Could try recording a test IVR directly from a phone connected to your system and see if that one works…

I Record a message from my phone connected to my system I try to enter the ext. number and it still says we have not received a valid response

that said its auto, inband, AVT/RFC2833 how do I cahange it to that ?

I had this happen when I was using some longer extension numbers (4 digits). I’m not sure why but when I had direct dialed extensions enabled but NOT listed as an IVR entry, no one could direct dial the 4 digit extensions. They could direct dial 3 digit extensions. You may be running into the same bug.

I change the Ext to 2 and 3 numbers I get the message but when I enter the ext. Nothing happens
we have not received a valid response

Make sure in the IVR settings you have it setup that you can direct dial an extension from the IVR.

Also check your DTMF settings, as it could be that your PBX isn’t receiving the correct DTMF tones.

Like (I think it was Dicko) said, check with your provider as to which form of DTMF you have to send.

This is my Trunk setting:


In your trunk settings, you can specify auto like this:


You can also set it individually for each extension, on the extension configuration page, and, depending on your phone, you may also need to specify it on each phone. (Cisco SPA’s the setting is on the Ext# tab)

Hello everyone,

I've been messing around with IVR for about 3 days looking on line and youtube videos as I finally have my PBX up and working as I am able to send and receive calls. I am still pretty new with freepbx but been working on this in my test lab for about 2 months now I just want to setup a basic IVR. I've uploaded my announcement and put in my EXT options in my IVR say:
EXT 1 -> Extensions -> 101 Kevin
EXT 2 -> Extensions -> 102 Robbie

I've also gone to the INBOUND Routes and clicked on my DID number that I have already created and scrolled all the way down too set destination where I set it to IVR and the name of the IVR that I created. I do get my voice recording but when I press 1 nothing happens. Am I to do some editing in CLI to the extensions.conf file? Sorry, I wish I could be more informative but I'm proud of what I was able to get done so far and there is a lot of good information out there which has helped me but I just can't get this part of my lab to work. Any help would be very much appreciated. I know I am missing something but I feel that I have looked everywhere and I am sure, no I know I am missing something.

Once again thank you everyone in advance for your patience and knowledge.  I did also have my extenstions set to 4 digits but have changed them to 3 digits now as per the previous blurbs above and still no go.

I can do dial by first/last name but I dont think that is as helpful if you dont know the person that your trying to call, so a setup like press 1 for Kevin would be more helpful than please enter the first 3 letters of the person your trying to call.

Just for anyone elses notes looking through this like I was. This issue occurs when there is no Announcement set on the IVR.

Set an announcement on your IVR (I uploaded the recording, just forgot to set it as an announcement) and the error message should go away.

Thanks much Goenks!

Hi I am having the same issue. I am using a Sangoma Vega 50 4 FXO Gateway as access to the PSTN for my FreePBX. I can not get the IVR to work. It has an announcement set for “dial 1 for this extension, dial 2 for this extension…” but when the user dials any number, a pause and a “invalid response” message is played. The gateway also will not give a hangup command to the pbx when the caller from the PSTN hangs up. So the line stays open indefinitely until the system is restarted (amportal restart). I have the extensions using rfc283. I tried inband audio dtmf setting on an extension but no difference.

Any ideas for a newbie?