IVR going to queue instead of extensions

Our IVR works great but lately when someone types 201 which is my extension, it goes to the queue 2 for support. No matter how fast or slow they type it, it picks up the 2 and goes right to support.

Any way to fix this?


are you sure you have checked the box to allow extension dialing?

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

Enable Direct Dial is checked.

What are the options for your IVR? If there’s an option for “2”, then Asterisk will detect that and jumps you to that option’s extension or dial plan tree.

It’s worked this way for over a year. All of a sudden, it’s doing this. I guess I’ll remove the IVR and re-create it. Hopefully that will help.

I recreated the IVR, still does the same thing. Is there some sort of DTMF timeout I’m missing here?


How can I at least debug this? My IVR worked fine for over a year now. The last upgrade screwed it up for some reason. I’ve tried to re-create our IVR with no luck. I can’t change my extension as I have biz cards, mailers,etc… and I can’t change our IVR as we paid someone to do it.

I did a yum update and now I am experiencing the exact same problem you are describing. All my extensions begin with 5 and my IVR has worked perfectly with direct dial for over a year. Since the update, every call goes to option #5 on my IVR. I have tried creating a new IVR (without a choice #5) but then it wouldn’t dial anything - you get “I am sorry that is an invalid extension”.

If anyone out there is experiencing the same problem and has found the solution I’d sure appreciate a reply.


I have tried checking and un-checking the box, applying the changes each time. Is there a timing issue that might be causing this problem?

This is what asterisk -vvvrc shows when the caller inputs an extension to the IVR:

-- Playing 'custom/IVR_Greeting-NEW' (language 'en')

== CDR updated on SIP/11234562815-08af0360
– Executing DBdel(“SIP/11234562815-08af0360”, “”) in new stack
– Executing Set(“SIP/11234562815-08af0360”, “__NODEST=”) in new stack
– Executing Goto(“SIP/11234562815-08af0360”, “ext-group|5|1”) in new stack
– Goto (ext-group,5,1)

Remember, this worked before and only recently stopped working.

I wish someone would help me fix this. Others must be having this issue as well.

You haven’t provided much information for anyone to help you. What did you update? Did you change Asterisk versions and if so from what version to what new version. Did you check that the dialplan being generated really has the local extensions exposed and is being properly generated? (look in extensions_additional.conf at the IVR code).

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

FreePBX 2.2.2

I have the same issue with a customer whose * server must sit behind SER, and use inband dtmf on the trunks. It’s because of his SER configuration that the * trunks must use inband – I can’t go into why here…

His IVR has three options: 1, 2, and 3. DirectDial is enabled.

1 -> 200
2 -> 201
3 -> 201

When I call in, and the IVR greeting/announcement is still playing, and I type “200”, I end up going to 2->201. If I WAIT until the greeting is over and type “200”, I then go to 200.

Here’s another case. From a SIP extension on that same * system, I can use the 7777 feature to simulate an incoming call. This SIP extension is setup to use inband dtmf. In this case, everything works as expected, whether the greeting/announcement is still playing or not. 200 goes to 200, 2 goes to 201, etc.

In my particular case, I think SER might be affecting this somehow; however, since I can call in through SER, and wait for the announcement to finish until I start punching numbers, and 200 then goes to 200, I’m not certain it’s SER’s fault. I’m trying to get logs from my customer’s SER box, but they’re having trouble with it.

This is a trixbox install. We moved from one VMWare Server farm to another and it was either right after the move or after I ran yum update that the IVR stopped working. I was behind on patches, waiting for trixbox update and couldn’t wait any longer, so when I moved/updated I was running the latest version of Asterisk and FreePBX that the latest trix image uses. Since then, I have updated to latest FreePBX and Asterisk with all the OS updates so I am current on all

I’m only familiar enough with this stuff to be dangerous, so I am attaching the dialplan for my IVR from extensions_additional.conf and would appreciate any comments/suggestions:

include => ivr-2-custom
include => ext-findmefollow
include => ext-local
include => app-directory
exten => #,1,Goto(app-directory,#,1)
exten => h,1,Hangup
exten => s,1,Set(LOOPCOUNT=0)
exten => s,n,Set(__DIR-CONTEXT=default)
exten => s,n,Set(_IVR_CONTEXT=${CONTEXT})
exten => s,n,GotoIf($["${CDR(disposition)}" = “ANSWERED”]?begin)
exten => s,n,Answer
exten => s,n,Wait(1)
exten => s,n(begin),Set(TIMEOUT(digit)=3)
exten => s,n,Set(TIMEOUT(response)=10)
exten => s,n,Background(custom/IVR_Greeting-NEW)
exten => s,n,WaitExten(,)
exten => hang,1,Playback(vm-goodbye)
exten => hang,n,Hangup
exten => 0,1,dbDel(${BLKVM_OVERRIDE})
exten => 0,n,Set(__NODEST=)
exten => 0,n,Goto(ext-group,100,1)
exten => 1,1,dbDel(${BLKVM_OVERRIDE})
exten => 1,n,Set(__NODEST=)
exten => 1,n,Goto(ext-group,1,1)
exten => 2,1,dbDel(${BLKVM_OVERRIDE})
exten => 2,n,Set(__NODEST=)
exten => 2,n,Goto(ext-group,2,1)
exten => 3,1,dbDel(${BLKVM_OVERRIDE})
exten => 3,n,Set(__NODEST=)
exten => 3,n,Goto(ext-group,3,1)
exten => 4,1,dbDel(${BLKVM_OVERRIDE})
exten => 4,n,Set(__NODEST=)
exten => 4,n,Goto(ext-group,4,1)
exten => 5,1,dbDel(${BLKVM_OVERRIDE})
exten => 5,n,Set(__NODEST=)
exten => 5,n,Goto(ext-group,5,1)
exten => i,1,Playback(invalid)
exten => i,n,Goto(loop,1)
exten => t,1,Goto(loop,1)
exten => loop,1,Set(LOOPCOUNT=$[${LOOPCOUNT} + 1])
exten => loop,n,GotoIf($[${LOOPCOUNT} > 2]?hang,1)
exten => loop,n,Goto(ivr-2,s,begin)
exten => return,1,Set(IVR_CONTEXT=${CONTEXT})
exten => return,n,Set(IVR_CONTEXT${CONTEXT}=${IVR_CONTEXT
exten => return,n,Goto(ivr-2,s,begin)
exten => fax,1,Goto(ext-fax,in_fax,1)

; end of [ivr-2]

I just rebuilt a brand new server from scratch - bright and shiny new. Same problem.

I did not pull any configs from the old server - not a scrap except for trunk registrations and my IVR recording. Everything else was from scratch.

Now THIS is frustrating.


I have two vm’s now - one here in the office and one on the internet. Both are identical except for their location. Both display the same characteristics - i.e. - the IVR is broken as stated above.

I have found that here in the office I can dial 7777 and then the IVR (including direct dial) works, but anytime I come in over my trunk line it fails. I am using ViaTalk as my provider and have a buddy who uses them as well. He is having the same problem I am.

He has another trunk with another provider and just tested it. The problem definitely lies with ViaTalk (at least mine does).

Check this thread at trixbox.org: http://www.trixbox.org/forums/trixbox-forums/trunks/ivr-dtmf-issues-viatalk-viatalk-call

I just heard back on my Viatalk ticket and they changed the dtmfmode=rfc2833. I made the modification on my trunks and all is now good.