IVR - DTMF not recognized?

we have 3 companies on the exact same PBX system. two company IVR is working fine while the other will not accept DTMF tone correctly. we have never had an issue with DTMF tone with them.if I change dtmf to “dtmfmode=rfc2833,” the 3rd one is working fine now but other 2 which are inband are not working . any suggestion?

Our current config is:

dtmfmode=auto

You have to change your sip file setting and check what band you are using like inband or rfc2833 in sip_general_conf, Hope your DTMF will work on IVR.

I usually recommend against auto DTMF, the algorithm is about 50% accurate.

You need to tell us much more about your system including FreePBX version, Phone type (and what there DTMF settings are) trunk setup etc.

Every provider that I know recommends rfc2833. If it works on one, why not try it on the other two?

2.10.0.1 FreePBX VER

Asterisk (Ver. 1.8.14.0)

sip_custom.conf settings are below
dtmfmode=inband
dtmfmode=rfc2833

sip_general_custom.conf settings are below
allow=g729
allow=ulaw
dtmfmode=inband

sip_additional.conf
[gz local]
host=2.10.23.2
type=friend
allow=all
dtmfmode=rfc2833
context=from-trunk-sip-gz loca

sip_additional.conf
[599]
type=friend
secret=password123
qualify=yes
port=5060
pickupgroup=
nat=yes
[email protected]
host=dynamic
dtmfmode=rfc2833
dial=SIP/599
context=from-internal
canreinvite=no
callgroup=
callerid=device <599>
accountcode=
call-limit=50
faxdetect=no

Its works but only one at the same time, if I enable dtmfmode=rfc2933 than its works on one number but when I put dtmfmode=inband than its works on the other two numbers. but do not work on all three numbers at the same time.

You did not answer yet…

Adhominem stepped in.

I was just suggesting what you needed to post to get a response.

This is a good beginner explanation of inband vs out of band with some recommendations and tips in case you don’t know the basics.
http://www.voipmechanic.com/dtmf-issues.htm

You didn’t mention anything about your trunks. Are all these numbers and companies on the same trunk(s) and behind the same firewall? Since dtmf out of band uses port 5060 you might want to see if you have something going on with your firewall. Try enable a range from 5059-5061.

Could also have something to do with your trunk provider but without more details of your setup I am just speculating at this point.

Hi,
I Have installed freePBX 2.8.1 version and asterisk 1.8.11.0 version.
Internally when i dialled IVR number able to hear IVR Play but DTMF to reach extn. is not accepting and also Conference number DTMF also not accepting.
Can you suggest?

HI,
I have configure it out the problem and my IVR is now playing can you tell me the sip_general_custom.conf settings than able to tell you the…

Hello all,

Can anybody help me with this custom settings i want to add in Freepbx how to add it and where please help me out.

Each business day (Monday through Friday), from 9:00 am to 4pm, the phone calls will be forwarded to a designated agency as follows:

Monday: XXXXX Services (540) XXX-8900
Email: [email protected]
Tuesday: XXXX Services (540) XXX-5599
Email: [email protected]
Wednesday: XXXX Place (540XXX-9303
Email: [email protected]
Thursday: XXXXX Services store (540) XXX-8900
Email: [email protected]
Friday: XXXXX Services company (540XX-3202
Email: [email protected]

If the line is busy when a caller calls in, the message the caller leaves will automatically go into the designated email box.

After 4:00 pm and on holidays and weekends, the messages will be sent to the email address of the next agency per the schedule.

Hello,
I am setting up an IVR system internally in my lab. Theres no external routing for now. I have been able to record the voice and when i dial the extension number I do hear the announcement: “Press 1 to go to extension 100” but when I press 1 nothing happens. I have set the dtmfmode to RFC2833.
Can someone please help me.
Thank you very much for your contribution.

Hi I’m fairly new to FreePBX and I am having trouble sending the correct dtmf tones to certain public services. I got locked out of my bank for example for entering my telephone banking number apparently incorrectly 3 times. It appears that tones are getting repeated. Eg if I key 1234, the remote server gets it as 11223344. Any ideas appreciated many thanks.

This may not be a pbx problem I have just noticed that’s if I use my mobile phone with a sip client no problems are experienced sending tones. I only get problems when I am calling using my Linksys pap2t adaptor.

Hi All,

I experienced the same issue. When I call our office mainline number (SIP trunk) and dials an extension number (for example: 806) in the CLI logs it shows 880066. We have another PBX system from other manufacturer and it’s working fine using the same SIP trunk.

Our SIP trunk provider uses inband dtmf. But using freepbx using inband or rfc2833 is no use.

I tried to login to sip.conf of the other PBX it shows that it is using rfc2833. I tried to login to freepbx sip_general_custom.conf but nothing is in there. Might be setting up this sip_general_custom.conf to refc=2833 will solve the issue.

kindly advise.

Thanks

You can signal DTMF in a few ways, Inband and Outofband, Outofband can be info or rfc2833, having more than one active will often cause duplicate digits, some amelioration can be done in asterisk by using dtmfmode=auto, but it is not guaranteed to work across all networked devices, so you will have to play with it until it works between them all.

Hi Dicko,

Thanks for your reply.

I tried setting the SIP trunk using dtmf=auto but still the same. Where you want me to set this dtmf? is it on the trunk or in the PBX itself? Where can we set it in the GUI? In other asterisk PBX, it is under SIP settings on there GUI which is sip.conf in CLI. In freepbx sip.conf nothing is in there as well.

Kindly advise.

Thanks

In the trunk settings for outbound. Read the rop of sip.conf before messing with it.