IVR Direct Dial GUI Not working

Hi -
IVR Module version 16.0.5

I have created a company directory “All employees”.
When I go and edit my IVR, even though I select the “Enable direct dial: All employees” , the validated GUI comes back with “Enable direct dial: Disabled”

When I look at the conf file extensions_additional.conf, I see:
include => from-ivy-directory-1
which is the All employees directory I created.

Therefore, the GUI does not represent what the configuration file has.
Anyone else with this?

Testing with the same IVR module version and I can’t repro this. I have no issues configuring a directory for direct dial. Perhaps sharing a call trace via pastebin will offer a clue.

Hi Lorne,
I installed ClearlyIP Module, which have nothing to do as far as I know with the IVR Module.
Will you still be interested into looking into the logs? Or because there is a 3rd party involve, then you won’t?

Thank you

Post the logs, no said anything about a 3rd party module…

Here is the past bin from the amportal a dbug command

Here the the past bin from the asterisk -rvvv console

Any update on this one? I still have the issue.

No, your post disappeared, use the sangoma pastebin or repost it permanently

Looks like it’s down… http://pastebin.freepbx.org

A PHP Error was encountered

Severity: Warning

Message: mysqli::real_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known

Filename: mysqli/mysqli_driver.php

Line Number: 201


File: /usr/local/stikked/Stikked-0.12.0/htdocs/application/controllers/Main.php
Line: 41
Function: __construct

File: /usr/local/stikked/Stikked-0.12.0/htdocs/index.php
Line: 315
Function: require_once

It is back up.

No. Still same error here as of 2023.03.13 @ 09:13 EST

A Database Error Occurred

Unable to connect to your database server using the provided settings.

Filename: controllers/Main.php

Line Number: 41

It went down again.

You can use pastebin.com if you want, but don’t set expire

Let’s try again…


uniqueID and call-ID traces

Call came in, caller pressed 222 in the IVR and the phone system called extension 222.

Do you expect a different behavior?

Yes - I expected this not to work, since I have “Enable direct dial: Disabled” in the IVR…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.